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1. Getting Started

This chapter introduces you to MacGourmet Deluxe.
Welcome to MacGourmet! In this chapter, you will be introduced to the basics of 
MacGourmet a recipe, wine and cooking note organizer.

Running MacGourmet Deluxe for the First Time
When you start MacGourmet Deluxe for the first time you will be asked a few questions 
to get you started:

Upgrading from MacGourmet version 1

If you"ve used the first version of MacGourmet, please contact support. We"ll help you 
migrate your data to version 2.

Creating your MacGourmet library

The next prompt will ask you where you"d like to store your library. Press the “Use 
Documents” button to keep your library in your Documents folder. Press the “Specify 
Location” button to specify a different folder for your library.

9
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Wherever you decide to create your database, all of your information will be stored in a 
file named MacGourmetDatabase. Don"t forget to back this library file up from time to 
time.

This database file cannot be moved (without changing the location in Advanced pref-
erences) or renamed, and if this happens, MacGourmet will think that it needs to create 
a new database when you launch it after doing either of these things. If this happens, 
you can restore your information by just moving your MacGourmetDatabase file back to 
the original location or by changing the name back to what it was originally.

Loading the sample recipes and notes

If you want to add some sample recipes, press the “Yes, Please” button to add them to 
your initial library. If you"d rather start with an empty library, just press the “No Thanks” 
button.
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Installing a QuickPick for .Mac Backup

If you have .Mac and you are using the Backup application, you can install a QuickPick 
that will backup any of your MacGourmet related information like templates.

1. Launch Backup

2. Create a new plan or double-click an existing plan in Backup window.

3. Click the Add (+) button below the Backup Items list.

4. Choose MacGourmet library by clicking the checkbox next to it. The MGD database 
located in your home folder will be backed up.

5. Click the Done button.

Note that you will still have to backup your MacGourmet library. If you decided to create 
it in your Documents folder, and you have Backup set to save your Documents, then 
your library will already be backed up. If you specified another location, make sure that 
you use Backup to add the location you chose for your library, so that it gets backed up 
as well.
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Feature Overview

Your recipe 
box has 3 
main lists for 
storing your 
items, “My 
Recipes,” 
“My Notes” 
and “My 
Wine Notes.” 
Each of these 
lists holds the 
master copy 
of each re-
spective item 
type in your 
database. 
You can eas-
ily put items 
in lists that 
you create, 
but they 
really just re-
fer back to the master copy. 

For instance, if you create three of your own lists and then drag a recipe from your “My 
Recipes” list to each of these three lists, you will see four copies of your recipe in differ-
ent locations. There will, however, only be one REAL copy. The other three recipes that 
you see in the lists you created are really just pointers back to the master copy. This 
means that modifying that recipe anywhere will change all the instances of that recipe, 
no matter where you put it. 

If you delete an item in one of your lists, it is removed from your list. It is not removed 
from your database however, unless you explicitly delete it, or you delete it from one of 
your “My” lists.

My Recipes

Your “My Recipes” list shows you all of the recipes in your database. This list can only 
contain recipes. If you delete a recipe from this list, it will get deleted from your data-
base.
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My Notes

Your “My Notes” list like your “My Recipes” list, shows you all of your notes. Deleting 
and copying notes from this list works like deleting and copying recipes from your “My 
Recipes” list.

My Shopping Lists

This list shows you all of your current shopping lists. Unlike recipes, wine and cooking 
notes, shopping lists can only exist in this list. When you create a shopping list from one 
or many recipes, it will get added to this list. Deleting a shopping list from this list will de-
lete it from your database. You can add a new shopping list by dragging one or more 
recipes to this list, in addition to the normal ways of creating new items. For more infor-
mation on shopping lists, please see section 10.

My Wine Notes

Your “My Wine Notes” like your “My Recipes” list, shows you all of your wine notes. De-
leting and copying notes from this list works like deleting and copying recipes from your 
“My Recipes” list.

Clippings

The Clippings list contains selections of text “clipped” from web sites, using the “Make 
MacGourmet Text Clipping” menu item in the Services menu, by dragging text from 
other applications to this list, and by pasting text into this list. Clippings can be double-
clicked and imported using the Recipe Import Assistant.

Featured

Featured lists are lists of recipes, etc., that are published on the MacGourmet website 
and displayed within MacGourmet. This list is retrieved from the web, and includes lots 
of recipe packages put together for MacGourmet users. Importing them is as simple as 
finding the packages or recipes that you want to try and dragging the package or recipe 
image to a list in your Recipe Box, or by clicking on the image for a package or recipe. 
This content will be updated regularly and will offer users a quick and easy way to add 
great recipes to their collections.
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Find Results

The results of searches you do using the Find menu appear in this list.

Last Import

Your "Last Import" list displays the items that were added to your database the last time 
you imported something. Every time you do an import, the current list items are re-
placed with any newly imported items. Don't worry though, because even though the 
items were removed from your "Last Import" list, you will still be able to find them in your 
appropriate "My" list and anywhere you might have copied them.

Smart Lists

Smart Lists allow you to create lists of items that match find criteria you specify. Once 
created, they can be configured to keep themselves up-to-date as you make changes to 
your database, like imports, rating changes, etc.

To create a new Recipe Smart List:
1. Click on the view that holds all of your lists.

2. Right-click or Ctrl-click on the list and choose New > Smart Recipe List from the 
menu.

3. Alternatively, choose File > New > Smart Recipe List.

User Lists

(Lists and Sub-lists Created By You)

User lists, unlike your master lists, can contain sub-lists, and any kind of item. Also, un-
like your master lists, deleting an item from a user list doesn't remove it from your data-
base. It only removes it from its user list. Unless you delete an item from a master list, it 
can be added to and deleted from any user list, and moved and copied to any location 
that you would like. Removing an item from its master list however, will also remove it 
from any list that contains it. This means that if you remove a recipe from your “My 
Recipes” master list, it will also be removed from all of your user lists that contain it.

Creating a new User List
1. Click on the left-hand view that holds all of your lists, that that it has the focus.

2. Press the “+” button at the bottom left of your recipe box.
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Creating a sub-list within a list
1. Select the list you want to add the new sub-list to.

2. Right-click or Ctrl-click on the list and choose New > List from the menu.

3. Alternatively, choose File > New > List or !"G (shift-"-G).

Recipe Box Widescreen and Normal Display Modes
Your recipe box is able to display your information in two different modes, widescreen 
and normal. Widescreen mode stacks your columns side-by-side and can better take 
advantage of more recent Apple widescreen displays. Normal mode uses a display simi-
lar to that used by Apple"s Mail application. The mode used can be set in Preferences.

In addition to these modes, the column that displays the items in the main selected list 
can also be shown using either the normal multi-column “list”, or using a “summary” 
version of the list, which are more suited to widescreen mode. When displayed using 
summaries, the items in the list will be displayed in a single column, with taller rows that 
contain a summary of information for the selected item, including its image, etc. To tog-
gle between list and summary lists, press the button at the bottom right of the main list 
column resize handle.
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Customizing Table Columns
The table columns of each type of recipe box list is customizable. This lets you show 
only the columns you are interested in. It also allows you to display them in the order 
you desire.

Accessing the list of columns to display
Hold the right mouse button down (or press the ctrl key on your keyboard and hold 
down the mouse button) and click on any table column. When you do this, a menu with 
all of the available columns is displayed, with a check mark next to all of the columns 
that are set to display. If you want to hide a column, just select a checked column name 
from the list, the checkbox next to the item will no longer appear, and the column will be 
hidden in your recipe box. To show column, select an unchecked column from the list to 
add a checkbox, and the column will be then displayed.

Rearranging the columns
Click on a column header and drag it to a new position.

Note that there are different columns for different list types. For instance, selecting a list 
that only displays recipes will have recipe-related columns available, selecting a wine 
note will have wine-note related, etc. User lists, because they can contain any type of 
item, will only display columns that are common to all of the items it can contain.
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Creating and Editing
Edit and view recipes and 
notes by double-clicking on an 
item in a list to open the editor. 

Creating an item is done by se-
lecting the appropriate menu 
item from the File > New sub-
menu. You can also use the 
“New” toolbar item, which will 
create a new item for the se-
lected list. If you are in one of 
your user lists, which can con-
tain different kinds of items, 
you will be prompted for the 
type of item to create.

Double-clicking on a recipe opens the 
recipe editor. The editor allows you to 
view and change the item"s informa-
tion, including adding notes and pic-
tures.

Hint: You can display editors as both 
dialog windows and sheets, which are 
attached to the main window. To spec-
ify the editor style you"d like to use, 
change the “Display editors as 
sheets” option in Preferences.
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The Chef View - Your Kitchen Cooking Helper
If you have your laptop or computer in the kitchen with you while you cook, you can dis-
play any recipes you are working on in a Chef View. Chef Views are windows containing 
a view of your recipe that is optimized for use while cooking. The text is large enough so 
that you can read the ingredients and directions from a distance. This view also displays 
only what you need to see while cooking, the list of ingredients and the directions. This 
means no extra fluff like the pictures, ads and web navigation that you get when display-
ing a recipe on a web site in a web browser.

Viewing More than One List at a Time
Not content with just viewing and organizing your recipes and notes in your recipe box? 
No problem. MacGourmet allows you to open lists in their own windows, with their own 
item views, for extra flexibility. This allows you to see one of your lists in its own “recipe 
box” like window, without a view on the left side. In addition, updating or adding anything 
to a list when viewed in its own window will also cause the update to happen in your 
main recipe box, keeping everything synchronized for you. 

To view a list in its own window, select a list and either press the “View List” toolbar item, 
or choose “View List” from the File menu.
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Changing the Display Layout of Recipes and Notes
MacGourmet doesn't give you just one set of fonts and colors for displaying your recipes 
and notes. Just go to the General Preferences tab and select the look you want with a 
recipe selected in your recipe box to see the layout change.

Viewing Larger Versions of Your Images
While the image for a selected item may be small, to make it easier to display more in-
formation, you can see a larger size of any image, if there is one, by clicking on the im-
age in your recipe box.

Viewing More than One Item at a Time
Displaying read-only versions of more than one item at a time can be done by choosing 
File > Display Item for each item.
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Recipe Box Toolbar Icons

New - Add a new item

Delete - Delete the selected item or items

Get Info - Display the editor for the item

New Shopping List - Create a new shopping list using the selected recipes

Chef View - Display the chef"s view for the selected items

Print - Print the selected items

Export - Export the selected items

Import - Import items into your library

Library Browser - Browse the information in your library

Send Email - Email the selected items

View List - Display the selected list in a separate window

Nutrition Database - Display the database main window 

Weekly Planner - Display the Mealplan weekly planner window 

Cookbook Builder - Display the Cookbook builder window 
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2. Creating and Editing Recipes

This section describes creating and editing recipes.

Creating Recipes
To create a new recipe:

1. Choose File > New > Recipe ("-N). 

A new empty recipe in the currently selected list is created and the info window is dis-
played.

Editing Recipes
You can edit and view recipes simply by double-clicking on one in one of your lists or by 
selecting something in your recipe box and choosing File > Get Info.

The Info Tab

1. The recipe name.

2. The source of the recipe. 
This is where the recipe 
came from.

3. Any additional source 
info you"d like to note, 
like the author or a cook-
book.

4. Free-form area where 
you can enter any key-
words or text that you"d 
like associated with the 
recipe.

5. The cuisine for the rec-
ipe, with up to 3 levels of 
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specification, like Asian: East Asian: Hunan.

6. The course in which the recipe would normally be served.

7. The yield of the recipe, such as 24 cookies. This is different from servings, which are 
used for nutritional calculation and which can only be a number.

8. The actual number of servings the recipe makes.

9. The difficulty level of the recipe, from easy to hard.

10.Any categories for the recipe. Categories are great for searching and organizing 

your recipes. Fields marked with a  are categories you"ve added. Fields marked 

with a  are system categories and categories marked with a  are locked and 
can"t be deleted.
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The Ingredients Tab

1. The quantity needed for 
an ingredient.

2. The measurement of the 
ingredient.

3. What the ingredient ac-
tually is.

4. Any directions associ-
ated with the ingredient, 
like “chopped” or “diced”

5. Whether or not an ingre-
dient is a divider. A di-
vider ingredient is one 
used only to separate 
ingredient groups from 
each other.

6. Whether or not an ingredient is one of the main recipe ingredients. Marking an in-
gredient as a “main” ingredient makes it easier to search.

7. Add a new ingredient, or delete any selected ingredients.

8. Change the scale of the recipe. Enter any number you want here and the ingredients 
will change to reflect the new amount.

9. The measurement system used by the ingredient, U.S. Standard or metric.
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The Directions Tab

The directions tab provides 
a place for the step-by-step 
how-to information about 
preparing the recipe.

Press the Previous button to 
go to the last recipe and 
Next to go to the following 
button. 

24



The Preparation Tab

The type of time, like “Start 
to Finish” or “Prep”

10.The amount and units, 
for instance 25 Minutes, 
or 1 Hour 30 Minutes.

11.Add a new preparation 
time, or delete any se-
lected times.

12.Any special equipment 
that is required by the 
recipe. Check any that 
are needed. Fields 

marked with a  are 
equipment you"ve added. 

Fields marked with a  
are system equipment 
and equipment marked 

with a  are locked and can"t be deleted.
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The Notes Tab

1. Enter a summary here. 
This can be an introduc-
tion to the recipe, why it"s 
great, a little story asso-
ciated with it, etc.

2. Any notes helpful when 
making the recipe.

3. Allows the recipe to be 
marked as one that you 
have prepared.

4. A rating of how much you 
enjoyed the recipe.
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The Picture Tab

The area that displays the 
primary image for the recipe. 
You can drag and drop an 
image to this area to change 
the picture, or select it and 
choose Edit > Paste.

1. The Crop Box. Dragging 
this box around and 
pressing the “Crop” but-
ton allows you to save 
only part of the image as 
the primary image for the 
recipe.

2. Clears the current pic-
ture, making it so that the 
recipe no longer has a 
picture.

3. Uses the area sur-
rounded by the “Crop box” to specify a smaller, more focused version of an image as 
the primary image.

4. Resets a cropped image to the original version.

5. Allows an image for the recipe to be opened from your computer"s disk drive.

6. Changes the size of the crop box.
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The Nutrition Tab

The nutrition notes tab con-
tains two additional tabs. 
Notes and Calculated.

Notes is a text area for dis-
playing the recipe"s already-
calculated nutritional infor-
mation.

The Calculated tab contains 
the tables that enable you to 
calculate nutritional data for 
your recipes. For more in-
formation, please see sec-
tion 12, Nutritional Analysis.
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3. Creating and Editing Wine Notes

This section describes creating and editing wine notes.

Creating Wine Notes
To create a new wine note, choose File > New > Wine Note (!-"-W). This will create a 
new empty wine note in the currently selected list, provided it is editable and can con-
tain wine notes.

Editing Wine Notes
To edit and view notes by double-clicking on one in a list or by selecting something in 
your recipe box and choosing File > Get Info.

The Info Tab

1. The name of the winery 
that produces the wine.

2. The name of the wine.

3. The region the wine 
come from.

4. Any subregion for the 
wine.

5. The wine vintage.

6. The wine style, like light, 
medium, full-bodied, etc.

7. The wine type, such as 
Red: Cabernet Sauvi-
gnon.

8. Free-form area where you can enter any keywords or text that you"d like associated 
with a the note.

29
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The Tasting Notes Tab

1. My Rating - A rating of 
how much you enjoyed 
the wine.

2. Note area - Any notes or 
thoughts that you had 
about the wine after tast-
ing it.

The Winemaker"s Notes Tab

1. Record notes from the 
winemaker about their 
product.

2. Enter the web address of 
the winemaker in the Wi-
nemaker URL field.
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The Label Tab

The area that displays the 
primary image for the wine 
note. You can drag and drop 
an image to this area to 
change the picture, or select 
it and choose Edit > Paste.

1. The Crop Box area- 
Dragging this box around 
and pressing the “Crop” 
button allows you to save 
only part of the image as 
the primary image for the 
recipe.

2. Clear button - deletes the 
current picture, making it 
so that the recipe no 
longer has a picture.

3. Crop button - Uses the area surrounded by the “Crop box” to specify a smaller, more 
focused version of an image as the primary image.

4. Reset button - Reverts a cropped image to the original version.

5. Open button -Allows an image for the recipe to be opened from your computer"s disk 
drive.

6. Size Slider - Changes the size of the crop box.
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The Cellar Info Tab

Here is a spot for info about 
the purchase and storage of 
the wine.

1. Purchase location - The 
location where you pur-
chased the wine.

2. Purchase date -The date 
you purchased the wine.

3. Maturation date - The 
date the wine matures.

4. Date opened - The date 
you opened the bottle.

5. Number on hand - The 
number of bottles of the 
wine that you have on 
hand.

6. Price - The price you paid for each bottle.
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4. Creating and Editing Cooking Notes

This section describes creating and editing your cooking notes.

Creating Cooking Notes
To create a cooking note, choose File > New > Cooking Note (!-"-N). This will create 
an empty cooking note in the currently selected list, provided it is editable and  can con-
tain cooking notes.

Editing Cooking Notes
You can edit and view notes simply by double-clicking on one in a list or by selecting 
something in your recipe box and choosing File > Get Info.

The Info Tab

1. The cooking note title.

2. The source of the cook-
ing note.

3. Free-form area where 
you can enter any key-
words or text that you"d 
like associated with the 
cooking note.

4. The text of the cooking 
note.
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The Picture Tab

For a description of each component, see the Picture tab of the recipe editor.
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5. Searching

This chapter describes ways you can find recipes and notes
There are a variety of ways to find things in MacGourmet. You can quickly filter on cer-
tain fields, or all fields in your recipe box using the Search Field. You can search for 
recipes, wine notes and cooking notes using the basic search functionality. You can  
create Smart Lists that search for items based on criteria you specify: lists that keep 
themselves updated as you add and delete items. You can search for recipes based on 
ingredients you have and ingredients you do not have. Finally, you can do "Potluck" 
searches that return random selections from your recipe collection. This is great if you 
can't decide what to make!

The Search Field
The search field is found on the toolbar of your recipe box and your list views. It allows 
you to pick a field to search on and quickly filter the selected list based on whatever you 
type into this field.

Using Basic Search
Basic search allows you to search for recipes, wine notes and cooking notes using the 
fields that correspond to each of those items. For instance, you can search for recipes 
using name, keywords, source, etc. You can search for wine notes using vintage, the 
region or comments in a winemaker's note. When you search, your  results are dis-
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played in the “Find Results” list in your recipe box. Your find results will be saved for 
your current MacGourmet session, but quitting the application and restarting it later will 
clear the “Find Results” list, so that it does not get too cluttered with old searches.

L
Tip: You can move the cursor to the search field by press-

ing #"F (option-"-F).

Using “Cupboard Find”
Cupboard Find is an easy and quick way to find recipes based on ingredients you have 
and ingredients you do not have. For instance, the screenshot below shows a recipe 
search that calls for chicken and potatoes, but not garlic, because you don"t have any 
garlic. When your search is complete, your results are displayed in the Find Results list 
of your recipe box.

Displaying the Cupboard Find window

Choose Edit > Find > Cupboard Find... (You can also press "-F).
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Creating and Using Smart Lists
Let MacGourmet create recipe and note lists for you automatically with Smart Lists. 
Simply specify your criteria — like recipes you have prepared or recipes with a rating 
greater than 3 — and MacGourmet will do the rest. MacGourmet finds the items that 
match the things you specify and creates a list that updates itself automatically.

If you were to create a Smart List for recipes, using the values shown below, a new list 
would be created for you that displayed recipes that you have prepared with a rating 
that is greater than 3. As you marked more recipes as prepared, and rated others, this 
list would be updated to reflect these changes, provided you had the "Live updating" 
box checked. Checking the “Limit to” check box would allow the Smart list to show only 

20 of the recipes in the database that matched your list settings instead of all of them.

L
Note: Because Smart Lists are updated each time something in the 

database changes, adding more and more lists can slow response 

times in large databases. Large databases will respond most quickly 

when there are fewer lists that need updating.

Creating a new smart recipe list
1. Click on the view that holds all of your lists.

2. Choose File > New > Smart Recipe List. You can also right-click (or ctrl-click for one 
button mouse users) on the view that holds all of your lists and choose New > Smart 
Recipe List in the menu that pops up.

3. A new list will be added, which you can rename by double clicking on it. To edit a list, 
select it and choose Edit > Modify Smart List. You can also select it and right-click 
(or ctrl-click for one button mouse users) on it to display a menu, from which you can 
then choose “Modify Smart List.”
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Doing a Potluck Find
Can't decide on what to make? Not a problem. Potluck Find is a fun way to search for 5 
random recipes from your collection. To do a new Potluck Find:

Choose Edit > Find > Potluck Find.

Potluck Find can be used as often as you want, returning a new, different list of recipes 
each time you use it.

Finding Recipes, Wine Notes and Cooking Notes
You can search for each item type by selecting the appropriate command from the Find 
menu.

Finding recipes

Choose Edit > Find > Find Recipes..., or press $"R (ctrl-"-R).

Finding wine notes

Choose Edit > Find > Find Wine Notes..., or press $"W (ctrl-"-W).

Finding cooking notes

Choose Edit > Find > Find Cooking Notes..., or press $"R (ctrl-"-N).

When you use any of these commands, a Find window appropriate for the type of item 
you are searching for will be displayed, so that only the information appropriate to the 
type of item will be available for your search.

You can also search your library for potential duplicate recipes. Find Duplicates looks 
at the directions of each of your recipes and compares them to those of all of your other 
recipes to see if there are any that might be the same. The ones that look like duplicates 
are returned in a Find result, and added to the Find Results list in your recipe box.

Finding duplicate recipes
Choose Edit > Find > Find Duplicates

Creating Smart Lists from Find Results
You can easily turn your find results into smart lists:

1. Select the Find result in the list

2. Choose File > New > Smart List From Find, to turn it into a Smart List.

This will create a new Smart List that uses the criteria in the selected Find result.
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6. Importing and Exporting

This chapter describes ways of importing and exporting your in-
formation.
MacGourmet provides a variety of ways to get information into and out of your recipe 
box.

L
Note: If you do not see the “Make MacGourmet Text Clipping” menu 

item in the Services menu, try copying MacGourmet to the system Ap-

plications folder. You can also try logging out, and rebooting if that still 

doesn"t work. In rare cases you might have to reboot twice.

Using the MacGourmet Clipping Service
Getting recipes into MacGourmet is as easy as 1-2-3:

1. Go to your favorite recipe web site in your web browser and select the text of a rec-
ipe. Hint: It"s often easier to clip from a “Print” version of a recipe, which will 
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usually display a recipe without ads and web site navigation.

2. With the text of the recipe selected, and your browser the  front-most application, se-

lect "Make MacGourmet Text Clipping" from the Services menu, or press !"T 

(shift-"-T). Doing this will add a text clipping of the recipe to the Clippings list in 
your Recipe Box.

L
Note: Not all web browsers support the Services menu. Apple's 
Safari, Camino, and Opera all support the Services menu, but 
Firefox, iCab, Microsoft's Internet Explorer, Mozilla, and 
Netscape currently do not.

3. Double click your new clipping to bring up the Recipe Import Assistant. Copy or drag 
the text from the top text area into the appropriate fields and text areas. Make any 
corrections or modifications you desire. Text can also be copied to import fields by 
selecting text in the area at the top of the assistant and choosing the desired target 
from the popup menu below the top text area, and pressing the Set button. Alterna-
tively, each menu item has an associated keyboard shortcut. If your recipe is in the 
simple format: Title, summary, ingredients, directions, you can also choose Quick 
Fill, which will attempt to auto fill the fields for you. Tabs can be changed by pressing 

the "-% ("-left arrow) or "-& ("-right arrow). 

40



Before committing your new 
recipe, you can see what it will 
look like when it's imported in 
the import preview.

And that's it! Here is your new 
imported recipe selected in 
your recipe box!
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Making clippings (Alternate 
options)
In addition to using the Serv-
ices menu item to create and 
add clippings to your recipe 
box, you can also create clip-
pings by either dragging and 
dropping text from another ap-
plication to the Clippings list, or 
by copying text from another 
application, selecting the clip-
pings list in MacGourmet and 
choosing Edit > Paste. Once 
you"ve made a clipping, you 
can import it using the Assis-
tant, the same as you would a 
web clipping, which is de-
scribed above.
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Using the MacGourmet Recipe Web Page Import Service
MacGourmet makes it super easy to import recipes from certain, supported web sites 
including allrecipes.com, epicurious.com, foodnetwork.com, williams-sonoma.com, 
cookinglight.com and food.yahoo.com. 

1. Go to the recipe page on your favorite, supported web site. Note that you have to go 
to one of their standard recipe pages for the importer to work. Recipes on featured 
pages, special pages, etc. are not usually supported by the importer.

2. Select the entire URL in the address bar of your web browser.

3. Choose Services > MacGourmet > Import Recipe From Web Page, or press !"R

4. After a moment, a Recipe Import Assistant window (described above) will open with 
all of the recipe information already filled in. Verify that your information is correct, 
make any desired changes, and Save. Note: Occasionally, because of the many 
variations of information, sometimes the information will not be retrieved in its en-
tirety. When this happens, you can still make a web clipping and import the recipe 
that way.

Note: MacGourmet site plugins use web page “scraping” to get recipe information. Rec-
ipe web sites tend to change their code often, and this will sometimes break the web 
page import service for that site. If this happens, while waiting for a fix, you can still im-
port a recipe using the web clipping service.

L
MacGourmet can import files that have been saved in the follow-
ing formats:

MasterCook, MasterCook Mac, Meal-Master, CookWare Deluxe, 
Cook"n text, RecipeML, and Yum XML
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Using File Import and Export
You can choose to import existing files in various formats, described below:

Importing Recipes:
The image below shows a MasterCook import file selected.

While you should make sure that you 
select the correct file format for your 
import, MacGourmet will verify that 
the file you selected matches the se-
lected format before your import 
starts.

To import CookWare Deluxe files:

1. Choose File > Export from the 
menu bar.

2. Choose export type: Tab-
Separated Text.

3. Click Save.

4. Choose the fields to export in the next window that is displayed. Just use all of them. 

5. Using MacGourmet, choose File > Import...

6. Choose the text file you created, and select CookWare Deluxe for the format of the 
file to import.

To import Yum XML files:

1. Choose File > Export All Recipes > As XML Text...

2. Save the file to your hard drive.

3. Using MacGourmet, choose File > Import...

4. Choose the XML file you created, and select Yum XML for the format of the file to 
import.
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To import Cook"n text files:

1. Export

2. Using MacGourmet, choose File > Import...

3. Choose the text file you created, and select Cook"n for the format of the file to im-
port.

To import Recipe ML, MasterCook MXP and Meal-Master files:

1. Using MacGourmet, choose File > Import...

2. Choose the file you want to import and choose the appropriate file format, Reci-
peML, MasterCook MXP or Meal-Master.

L
Hint: To import recipe collections from MasterCook 4.06 for Mac-
intosh you need to take the collections files and convert them to 
MasterCook export files

To import MasterCook Mac files:

1. You need to open a collection, say "15-minute Meals" 

2. Go to the index, and select all of the recipes, or just the recipes that you want to ex-
port.

3. Select the "Export Selected Recipe(s)" menu item from the Recipe menu, and 
choose the "Mac Format" menu item in the save dialog.

This will create a file that is in the correct format for import into MacGourmet, a Master-
Cook Mac file. After saving the file as a "Mac Format" file, you can then import that file 
into MacGourmet.

You can also drag and drop an import file into your Recipe Box! Just select an import file 
in the Finder and drag it into one of your lists, or onto one of your lists. That's all there is 
to it.

Once imported, your new items can be found in both your appropriate "My" list, and in 
your "Last Import" list.
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Exporting Recipes and Notes
Exporting items is as easy as importing them. You can export recipes in a variety of 
formats, described below:

MacGourmet Export Files

The MacGourmet file export types include two different ways to export both text and bi-
nary versions of recipes, wine notes and notes. The formats with the word “Personal" 
appended to them will create export files that include both your personal ratings and 
whether you have prepared the recipe or not. Those MacGourmet formats not marked 
as personal will not include this information. This allows you to make export files that will 
preserve your own information, and files that are more generic, which is preferable 
when sharing your items with others.

When you choose to export MacGourmet Binary files, any embedded images will be 
saved in a format that is smaller and faster to import later. The text format is useful 
when putting your export files on a web site or sending them through email. In the text 
version of the format, any embedded images are converted to text, making them easier 
to share across different mail and web servers, but also making them larger.

iPod Notes

1. Choose the list or set of recipes in your recipe box that you"d like to export to your 
iPod.

2. Choose File > Export... and choose iPod Note as the format.

3. Choose the location to save your recipes. A folder containing your recipes will be 
created in this location. Note: if you want to group your recipes in sublists on your 
iPod, create and choose to export a list in your recipe box that has sublists.

4. Connect your iPod to your Mac, making sure that “Enable disk use” in Settings is 
checked when you inspect your iPod in iTunes.

5. Drag the folder that was created when you exported to the Notes folder on your 
iPod, then disconnect it.

6. You should now be able to browse your recipes as iPod notes.

Text and Rich Text

1. Choose the list or set of recipes in your recipe box that you"d like to export.

2. Choose File > Export... and choose either Text File or RTF File as the format.
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MasterCook, MasterCook Mac and Meal-Master

1. Choose the list or set of recipes in your recipe box that you"d like to export.

2. Choose File > Export... and choose MasterCook MXP, MasterCook Mac or Meal-
Master as the format.

Note that you can only export recipes when a format other than one of the MacGourmet 
formats is selected. Wine and general notes will be ignored.

Creating text versions of your recipes and notes
Additionally, you can select one or more items and choose Edit > Copy. Doing this will 
place text versions of the selected items into the Mac OS X Pasteboard, letting you then 
paste the text into other applications like Mail, TextEdit, Entourage, etc.

Exporting the names of items in a list
To export the names of all of the items in one of your recipe box lists, select the list, and 
choose Edit > Copy. This will add a text-based list of all of the item names in the list to 
your pasteboard, which you can then  paste into any application you"d like.
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7. Publishing Recipes and Notes to the Web

This chapter describes using the Web Publishing features.
MacGourmet allows you to publish your recipes, wine notes and general notes to the 
web, or to your local file system. This allows you to easily share what you've created, 
entered, etc. with others. You create and modify web site publications by going to the 
Publish panel in Preferences, and selecting the Sites tab.
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Publishing Recipes to .Mac
MacGourmet allows you to easily publish recipes, wine notes and notes to your Apple 
.Mac account. To create a new publication, click the Add button. This will display the 
sheet shown below.

Title - This field lets you 
specify the name of the 
publication. This name is 
used both for the publi-
cation's entry in the Pub-
lish menu, and as the 
title displayed on the in-
dex page of your publi-
cation.

Summary - This field 
allows you to specify a 
brief summary for your 
recipe and notes sites.

Server Type - This pop 
up menu lets you pick 
which type of server to 
write your data to. Cur-
rently .Mac, WebDAV, 
and Local disk are of-
fered.

Server - This text field 
specifies the address of 
the server to connect to. 
For .Mac this value is fixed.

Website URL -  This field is used to specify the base URL for your recipe site. This URL 
is the specification of how the user will get to your web site. You can change this to any-
thing you want, but it will also get updated automatically for you as well, using informa-
tion inserted into other fields. For .Mac this can usually be left as it is.

Publish Folder - This text field specifies the location on the server or file system where 
your files should be written. Note that when using .Mac, that the location Apple specifies 
is "/Sites/yoursitename" so while you can specify anything you want, the suggested lo-
cation starts with "Sites" followed by the name of a folder that will contain your site.

Create export files for published items - Checkbox that allows you to create 
MacGourmet export files as part of your publication, so that importing your recipes by 
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other users can be as simple as just dragging the image of an export file from a web 
page into MacGourmet.

Finally, the Template and Style pop up menus allow you to pick one of the included 
MacGourmet themes for your publication.

After creating the specification for your publication, you can publish it by choosing File > 
Publish.

The Publish menu contains your pub-
lications, listed by their titles. Select-
ing a publication from the menu will 
create all of the files necessary for 
your site, in the location you specified. 
Once the publication is complete, you 
can access it using the URL displayed 
in the field labeled "This site's address 
is:" when your publication is selected 
in the Publish preferences table.
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Publishing Your Recipes and Notes to your Weblog
In addition to being able to use MacGourmet to create websites for your recipes and 
notes, you can also publish them to your weblog, if you have one. To do that you first 
need to create a new Weblog definition. To do this go to the Publish panel in Prefer-
ences, and select the Weblogs tab.

Title - The title of your weblog settings.

Service - The service that your weblog uses. Currently supported are Blogger, Blojsom, 
MovableType and TypePad.

URI - The URL to the atom.xml file on your server. For example: 
http://www.mycoolblog.com/atom.xml

Title - The title of the weblog on your server that you want to post to. To refresh this list, 
press the button next to this popup menu.

Image URL - The URL to the images folder on your server. This is where your images 
will be uploaded, or where they are found if you upload them yourself (when using 
Blogger, which doesn"t support file uploads).

Recipe URL - The URL to the recipes folder on your server. This is where your recipes 
will be uploaded, or where they are found if you upload them yourself (when using 
Blogger, which doesn"t support file uploads).

Template - The template to use when publishing your weblog.

Publish immediately - Publish your new entry immediately, bypassing any draft phase.

Generate MacGourmet file - Create and upload (if supported) a file for each posted 
item. If upload is not supported, you will be prompted for a location to save the file so 
that you can upload it manually.

Include image file - Generate and upload (if supported) an image for each posted item. 
If upload is not supported, you will be prompted for a location to save the image so that 
you can upload it manually.

Posting to your weblog
To create a new post, select an item in your recipe box, and choose “Post to Weblog...” 
from the Tools menu. In the window that is displayed, select the blog you want to pub-
lish to at the top left, make any changes to the post text, and press the Post button.
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8. Using the Library Browser

This chapter describes modifying and searching your information, 
like categories, equipment and recipe ingredients.

L
NOTE: The Library Browser is a VERY powerful tool and caution 
should be exercised when using it to modify your information. 
Make sure you check your changes before pressing “Yes” when 
you are asked to confirm your change.

The Library Browser allows you to view and edit information in your database. The li-
brary browser has 3 tabs, Recipes, Cooking 

Notes, and Wine Notes. 

Each tab has a popup menu that displays the 
fields that can be browsed and edited. Select 
a field in the popup to display the information 
associated with the selected field in the list 
below. 

 = User created field

 = Default MacGourmet field

Either can be changed or deleted.

 = Locked field and can"t be changed. 

To change a field"s value, double-click on it, 
change the value and press Return when fin-
ished.

Selecting an item from the list updates the 
“Used By” table at the bottom of the library 
browser to display items that use the selected 
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value. To go to the item in your recipe box, double-click on the item in the “Used By” ta-
ble.

Some lists, like categories, are lists you can directly modify, and some, like Ingredient 
Descriptions, are built from the information you have entered into your database. Be-
cause of this, items in a list like “Ingredient Descriptions” can only be “deleted” by re-
moving the values from any items that are using them. If you change one of these val-
ues in the middle table, all of the items that use the value will be updated with the new 
value. When nothing uses a value, it is removed from the list.

To search for an item:

Click in the search field.

Enter the desired search text. Example: “Macaroni”.

As you type, the list below is filtered.
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9. Relating Recipes and Notes

This chapter describes making links between recipes and notes.

Linking Recipes and Notes
Link recipes and notes to remember recipes 
that go well together, wines that go well with 
recipes, and notes that are useful when pre-
paring certain recipes. 

Creating relationships between two things
1. Select an item in your Recipe Box and se-

lect Tools>Relationship Manager... The 
item shown at the top of the Relationship 
Manager is the name of the currently se-
lected item. To keep the selection from 
changing as you select items in your rec-
ipe box, press the “Locked” checkbox.

2. Find an item in one of your recipe box lists 
that you want to link to the currently se-
lected item and drag it to the Relationship Manager table. Selecting a new item 
changes the selected item in the Relationship Manager unless you"ve checked the 
lock checkbox. Note that it is possible to drag an item without selecting it by quickly 
clicking and dragging the item, in one motion.

3. Drop the item. A new relationship between the selected manager item and the 
dropped item will be created. This relationship is in both directions, which means, if 
you make a relationship between a “Roasted Lemon Chicken” recipe and a “How to 
roast a chicken” cooking note, you will see that relationship when viewing either item 
in your recipe box.

You can add more relationships or delete relationships by selecting the relationship in 
the "Related Items" table of the Relationship Manager and pressing the Delete key.

Double-clicking on an item in the relationship manager will select that item in your rec-
ipe box.
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10. Creating and Using Shopping Lists

This chapter describes ways to create, use and export shopping 
lists.

Creating a Shopping List
MacGourmet allows you easily to create shopping lists.

Creating a new shopping list
1. Select one or more recipes.

2. Next select “Shopping List From Selection” from the File > New menu. You can also 
select “Shopping List From Selection” from the “New” contextual menu by right click-
ing or command clicking on one of your selected recipes.

Additionally, you can create a new, blank shopping list by selecting the “Shopping List...” 
item from the File > New menu when you have your “My Shopping Lists” list selected in 
your recipe box.

Alternatively, you can also create a new shopping list by selecting one or more recipes 
and dragging and dropping the selection on the “My Shopping Lists” list on the left side 
of your recipe box.

Combining Shopping Lists
Two shopping lists can be merged by dragging one shopping list and dropping it onto 
another one. When shopping lists are merged, the ingredients in the list are combined.
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Editing Your Shopping Lists
Like recipes and wine notes, you can edit and view shopping lists simply by double-
clicking on one in a list. Double-clicking on a shopping list will open the shopping list 
editor which allows you to specify the name, and the items for a shopping list. The editor 
allows you to also specify fields like aisle and store for each item on your list. The editor 
also allows you 
do add non-
recipe items to 
your list.

To edit values in 
the editor table, 
just double-click 
on the column of 
the row you"d like 
to change. To add 
or remove a row, 
just press the ap-
propriate button 
located above the 
table. The button 
marked with a “+” 
will add a new 
row, the button 
marked with the 
“-” will delete the 
current selected 
rows.
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Maintaining the Shopping List Favorites List
Every shopping list displays a master Favorites list, shown above in the bottom section 
of the shopping list editor window. The favorites list is a place to keep often used items, 
such as pantry staples, so that they can be quickly added to any shopping list. To add 
one or more favorite items to a shopping list, just drag and drop the rows from the favor-
ites list to the shopping list. The favorites list can also be used to store pantry quantities, 
if desired as well.

The favorites list can be hidden by dragging the window splitter to the bottom of the 
window, or by double-clicking on it.

Items in the favorites list are also used to set the aisles, stores and categories for items 
whenever a new shopping list is created. For instance, if the favorites list has a row for 
“all-purpose flour” and a shopping list gets created that uses this ingredient, the values 
for the “all-purpose flour” favorite item are used to fill in the data for this item in the new 
shopping list.

Alternatively, if there are no favorites found, existing shopping lists are searched for this 
information and the items in a new shopping list are filled in using the values from exist-
ing shopping lists, so it"s also possible to keep a “master” shopping list that is used to fill 
in information automatically.

Exporting a Shopping List to Your PDA or to a Text File
MacGourmet lets you easily export your shopping lists to PDAs and to text files. To ex-
port a shopping list, select it in your recipe box. Next choose Export... from the File 
menu. Finally choose a name, location and format for your exported shopping list. 
MacGourmet currently supports HandyShopper and SplashShopper, and plain text ex-
port formats.
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11. Printing Recipes and Notes

This chapter describes how to print on regular paper and on 
sheets formatted 
for index cards.
MacGourmet offers you 
many printing options. 
You can print one item, 
or many items. You can 
print one item per page, 
or many to a page. You 
can also print on recipe 
cards, like the Avery 
5388 3x5 index cards, 
and the Avery 5386 4x6 
index cards.

To print, you just need to 
select one or many 
items in your recipe box 
and press the Print tool-
bar item, or select 
Print... from the File 
menu. Either action will 
cause the Print window 
to be displayed. The 
Print window allows you 
to choose the template you"d like to use for printing and gives you an approximate pre-
view of what your recipes or items will look like when printed. Note that this is only ap-
proximate. To really see what your print out will look like, press the “Print” button at the 
bottom of the Print window, which will display the Print Settings sheet, and press the 
“Preview” button found at the bottom left of the sheet.

There are two kinds of print templates, dynamic and fixed. Fixed templates are used for 
printing on fixed size cards, like Avery index cards. These pages must be printed one-at-
a-time. When a fixed template is chosen, a “Display Page” slider appears, allowing you 
to select the page you"d like to print. To print your selected page, press the Print button, 
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which will open the Print settings sheet for the selected page, allowing you to preview it, 
or send it to your printer.

Dynamic templates are printed on normal printer paper, and can be printed all at once. 

L
Note: You can only print one type of item at a time. This means that if 

you are in your recipe list, you can select as many recipes as you want 

and print them. However, if you are in a user list, you can only select 

multiple items of the same type.

To print each of your selected recipes on a separate page, check the “Print one item per 
page” check box. To change the print margins, press the “Set Margins” button. This will 
bring up up a sheet that allows you do set the top, bottom, left and right margins.
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12. Nutritional Analysis

This chapter describes the Nutritional Analysis feature of 
MacGourmet Deluxe
MacGourmet Deluxe gives you the ability to calculate the nutritional data for all of your 
recipes.

About MacGourmet Nutritional Information

Nutrition Analyses Based on USDA Database
MacGourmet is proud to use the abbreviated USDA National Nutrient Database for rec-
ipe nutrition analysis. Today, the National Nutrient Data Bank is a repository of informa-
tion for more than 130 nutrients and for over 7,000 foods.#It is made available in their 
principle database--the USDA National Nutrient Database for Standard Reference (SR).#

U.S. Department of Agriculture, Agricultural Research Service. 2006. USDA Nutrient Database for Stan-

dard Reference, Release 19. Nutrient Data Laboratory Home Page, http://www.ars.usda.gov/nutrientdata 

Note: Release numbers change as new versions are released.

Use MacGourmet Information with Care
The nutrition values that are calculated by MacGourmet are based on individual recipe 
ingredients. If a nutrient value is not available at this time, you will not find a mapping for 
the nutrient name. While Advenio takes the utmost care in providing you with the most 
accurate nutritional values possible, please note that this information is an estimate and 
is not intended for medical nutrition therapy. If you are following a strict diet for medical 
or dietary reasons, it is important that you, first, consult your physician or registered die-
titian before planning your meals based on MacGourmet nutritional analysis, and, sec-
ond, remain under appropriate medical supervision while using the nutrition information 
calculated by MacGourmet.
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Overview
The MacGourmet:Nutrition plug-in consists of a main window, which provides access of 
the nutrition database and nutrient items, and a floating heads up display (HUD) window 
that displays a summary of the calculated nutritional information for a recipe.

The Nutrition Database
Once the plug-in is installed, the main nutritional database window can be accessed 
from either the Nutrition menu, or the recipe box toolbar. The main window allows you to 
browse all of the nutritional items in the database as well as providing a source for the 
mappings between nutritional database items and your ingredients.

The main window consists 
of 3 areas, the main list or 
nutritional items, the nutri-
tional data for the selected 
item and the mappings 
from the selected item to 
ingredient names.

To find information on a 
nutritional item in the data-
base, you just need to type 
part of the nutrient name 
into the search field. As 
you type, results matching 
your search will be dis-
played. You can remove 
food groups from your 
search by right-clicking, or 
control-clicking on the nu-
tritional item table and un-
checking the category in 
the menu.

Once you find the nutri-
tional item you are looking 
for, selecting it will display 
the nutrient values for the 
item in the nutritional in-
formation table. The data in 
this table shows the nutritional information for the item for every 100 grams.

Selecting the item will also show you the ingredients in your recipe library that currently 
map to the item. For instance, in the image above, ingredients with a description of ei-
ther “chopped nuts” or “nuts” will use the selected nutritional item in the nutritional calcu-
lations for a recipe.
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The Mappings Table
The mappings table is the component of the recipe editor that links your recipe ingredi-
ents to their nutritional data items in the database (see Calculating Nutritional Data for a 
Recipe, below). In order to correctly calculate nutritional data, each ingredient must be 
mapped to an appropriate item in the nutritional database. Ingredients that have been 

mapped are marked with a  and will show the name of the nutritional item it maps to. 

Unmapped ingredients are marked with a . Unless a mapping is provided, these in-
gredients will not be used in the nutritional calculations for the recipe. To see the item in 
the database that the ingredient maps to, you just need to click on the  button next to 
the nutritional item name.

The Nutritional Info per Serving 
HUD
Found in the toolbar of the main nutri-
tional database window is a button to 
open the nutritional data per serving 
HUD window. You can also access this 
window from the Nutrition menu. This 
floating window allows you to browse a 
summary of the calculated data, per 
serving, for the recipe that is selected 
in your recipe box. If no data has been 
calculated, the values will be marked 
with a “--” where the calculated values 
would be displayed.
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The Calculation Details Window
When the nutritional data for a recipe is generated, information on the analysis is stored 
with the data, and can be viewed using the Calculation Details window, which can be 
opened either from the database window toolbar or the Nutrition menu. In this compo-
nent you will find the basics of how the calculation for each ingredient was done, any 
errors in the calculations, and any ingredients that were skipped when calculating the 
data, along with information on why a calculation failed or wasn"t included in the final 

results. Ingredients used successfully in the nutritional analysis are marked with a  in 
the table. Ingredients that were not used because of errors, or because there were no 

mappings, are listed with a . Clicking on each ingredient will show you the associated 
analysis information or error. You can also find warnings displayed in this window as 
well. Warnings are logged when a calculation is done but the data is possibly incorrect 
based on the resolution or mapping provided. When there are warnings, Nutrition has 
made a guess at the resolution, so these calculations should be verified for their 
accuracy.
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Calculating Nutritional Data for a Recipe
To calculate the nutritional values for a recipe, you have to select the Calculated sub-
section in the Recipe editor Nutrition tab.

This component shows each ingredient, and it"s equivalent nutrition database nutrient 
value. MacGourmet calculates nutritional values based on the ingredients that make up 
your recipes. To figure out the nutritional values for each ingredient, MacGourmet uses 
the concept of associating the ingredient name used in your recipe, and an equivalent 
nutritional database item, called a mapping. MacGourmet comes with many mappings 

predefined, and you"ll see these marked with a  in the “Nutrition Food Item” column 

when you view one of your recipes. Values marked with a  have not been mapped 
yet, because a mapping between the ingredient description and a nutritional item wasn"t 
found.

To correctly calculate 
the nutritional informa-
tion, as many ingredi-
ents as possible must 
be mapped to nutritional 
items. To create a new 
mapping, you just need 
to find the nutritional 
item in the database that 
is the closest match the 
ingredient, and drag and 
drop the item from the 
nutritional database to 
the ingredient row that 
needs a mapping. Once 
you do this, the correct 
nutritional values will 
available to calculate the 
nutritional information 
for the ingredient.
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The Weight Resolver: Providing Needed Additional Information
Sometimes, even after mapping an ingredient, you need to provide more information to 
calculate nutritional values.

An example is an ingre-
dient of “1 egg.” While 
this value is mapped to 
“Egg, whole, raw, fresh” 
in the nutritional data-
base, when you press 
the “Calculate” button, 
you will be asked to 
specify the size of the 
egg you are using, such 
as medium, large, or ex-
tra large. Once you pro-
vide this additional in-
formation, the correct 
values will be deter-
mined for the mapping. If 
you press cancel at any 
point, the calculation for 
the recipe will be can-
celed as well.

How do you decide what 
value to choose? You 
want to choose the item 
from the list that most 
resembles your ingredient. For instance, if your ingredient has a measurement of 3 ta-
blespoons, you"d want to choose the “1 tablespoon” choice. If tablespoon wasn"t an op-
tion “1 teaspoon” would also work (3 teaspoons in a tablespoon). If your ingredient is 
measured in something like slices, and you only have an option like “1 cup” you might 
have to figure out and change your ingredient so that it resolves correctly, by figuring 
out how many slices would be in a cup and changing your ingredient measurement. Fi-
nally, if you just want to skip this ingredient, choose “DO NOT RESOLVE” and it will be 
ignored when calculating the data.

When Mappings Are Not Found
While most ingredients will have mappings, occasionally you"ll find that the nutritional 
database doesn"t have a good match. When this happens, the nutritional information for 
the recipe has to be calculated without the ingredient. The USDA does update the data-
base often, though, so at some point all of the ingredients could be available for your 
calculations. You"ll be able to get this updated information simply by downloading and 
reinstalling a new version of the Nutrition plug-in, when it"s available.
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Recalculating Your Nutritional Information
While you can recalculate your nutritional information any time you desire, sometimes 
you will have to recalculate your information because of changes in ingredients, serv-
ings or mappings. When this happens, the table labeled “Calculated Nutritional Informa-
tion per Serving” will be marked with an alert message stating that the data displayed 
needs to be recalculated. When you press the Calculate button, the old values will be 
replaced with the new ones and the alert will be cleared.

Tips on Getting the Best Calculations
MacGourmet:Nutrition relies heavily on the USDA database of nutritional items to do 
calculations. To do this without having to force the use of someone else"s “standardized” 
ingredients in your recipes, it allows ingredients in recipes to be simply mapped to their 
equivalents in the nutrition database using a simple drag and drop process. This is easy 
enough but there are ways to make this easier.

For example:

You might have various ways of referring to boneless and skinless chicken breasts in 
your recipes:

• skinless chicken breasts

• chicken breasts, skinless

• boneless, skinless chicken breasts

• boneless and skinless chicken beasts

All of these would ultimately map to “Chicken, broilers or fryers, breast, meat only, raw”  
but each variation would have to be mapped by hand before a calculation could be done 
properly. Any new variations would also have to be mapped. However, if all of the vari-
ants were replaced with “boneless, skinless chicken breasts” and that description was 
used in most recipes, work would be saved. This isn"t always possible of course, but the 
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more standardized your information, the less work you"ll have when you do a calcula-
tion.

Another point worth mentioning: your choice of mappings can effect the accuracy of 
your calculations. Sometimes a mapping that seems to make sense, won"t when the 
calculation is done. You"ll see this when you press the Calculate button and the Weight 
Resolver is displayed. This is normal, because as described previously, if you have “1 
egg” in your recipe, the calculation needs to know the size of the egg you are using. The 
problem occurs, however, when none of the resolver options seem to be appropriate. 

For example:

A recipe calls for “1 can chili, no beans” which you map to “HORMEL chili, No beans, 
canned entree” in the nutrition database. When you go to calculate your information 
however, you are given the following options: 1 cup, 1 package yields, 1 serving. None 
of these resolutions are totally appropriate. Why? Well “1 can” cannot be converted to 1 
cup, because there is no way to know from that description how many cups are in a 
can. The same thing applies to the other resolutions. In this case, it"s a good idea to 
look for something more appropriate for your mapping. If nothing appropriate seems to 
be found, you should consider changing the ingredient to say “2 cups chili, about 1 can” 
because a weight for “1 cup” is one of the available options. If you do either of these, 
you"ll be able to resolve the weight and calculate the correct values for the ingredient. 

Typically, if your ingredients have measurements like “1 can” or “1 package,” it"s better 
for calculating nutrition if you change the ingredient measurement to include the 
amount, in cups, tablespoons, etc., adding the package or can value as an ingredient 
direction instead.

Another example: 

Your recipe calls for something like “1 salmon filet, about 1 1/2 pounds.” Your results will 
be better if you change the ingredient to be “1 1/2 pounds salmon, one filet” instead, be-
cause there is no straightforward way to map “1 salmon filet” to the nutritional database 
weight of “1/2 filet.” Why? Well 1/2 filet in the nutritional database is 159g. So to get an 
accurate calculation, the “filet” needs to be entered using that number, so you"d have to 
figure out how the filet in the recipe properly equates to the database weight, and adjust 
accordingly. If you do the conversion to “1 1/2 pounds” everything is taken care of for 
you.

Comparing MacGourmet:Nutrition Data to Data With a Recipe
A word on MacGourmet:Nutrition calculations vs. information you might already have for 
a recipe: While they should be in the same ballpark, the odds of them being nearly the 
same are slim, unless they were calculated in the same exact manner. Some calcula-
tions you have will be estimates, like the MacGourmet:Nutrition values. Some will be 
more accurate, because they were calculated in a lab. It"s difficult to make a direct com-
parison between both sets of data unless you know exactly how the recipe data was 
calculated. Just something to keep in mind.
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The values can also differ greatly based on the exact ingredients they used in their cal-
culations, and what you use in your mappings. For instance, some of your mappings 
may be approximate matches rather than exact matches. This can cause final values to 
be different. Not using the right mappings, or not choosing the best resolutions can also 
cause the final values to be different, sometimes by a significant amount. For example, 
if you have an ingredient of “5 cm Ginger root,” you"ll find that none of the resolutions 
match this measurement. If possible, figure out this amount in the units of the easiest 
resolution you see, i.e. what 5 cm of ginger root might be in slices, cups, teaspoons or 
grams.

The rules of thumb for good calculations are essentially these: Start with a recipe that is 
as clean and consistent as possible. Then, when mapping, make sure you choose the 
best mappings possible. Finally, try and make sure that your ingredients resolve in the 
best way you can. When in doubt about the numbers, check the Calculation Details 
window to see just how the data was generated. This information can give you insight 
into ways to improve your mappings and resolutions. If you follow these rules, you"ll get 
data that is as accurate as estimated nutritional data can be.

Adding Your Own Nutritional Items
Sometimes you"ll find that the USDA hasn"t defined values or weights for an ingredient 
that your recipe uses. You might, however, have the nutritional information from the 
package available to you. In these instances, you can add new items to your database 
for these ingredients, and then make mappings to them just like you make mappings to 
the default USDA items that come with Nutrition.

Adding a New Nutritional Item
To add a new item, choose Nutrition > Add Item or press the “New Item” button in the 
toolbar. This will open a window that allows you to add information commonly found on 
product packages in the “Nutrition Facts” box for your 
item.

After filling in the name for your item and choosing the 
group it belongs too, you must fill in the “Serving Size” and 
“Weight” fields for your item. It"s best to enter the size in as 
clear a manner as possible. For instance, as “1 cup” or “1 
tablespoon.”

68



At times you might have to do 
your own conversion for your 
item to work properly. An ex-
ample of this is when you want 
to enter the information for “1 
can cream of chicken soup.” 
The USDA doesn"t offer a 
weight for 1 can, so you"d have 
to enter your own item, unless 
you"re willing to convert your 
ingredient into cups. Unfortu-
nately, when you look at the 
can you find it lists the amount 
for 1 cup in milliliters, not in 
grams, and your item weight 
has to be entered in grams. To 
solve this problem, you can 
find, by doing a search in the 
nutrition database, that the 
USDA does provide a meas-
urement for the soup you are 
using of 124g for each 1/2 cup. 
The soup can lists that there 
are 2.5 1/2 cup servings in 
each can, so you can then fill in 
“1 can” for your Serving Size, and 310g for your Weight (124g x 2.5 = 310g). Now, if you 
map your soup ingredient to your nutritional item, you can do your calculation correctly 
when your ingredient is in cans.

You"ll find items you"ve added in the list, marked with the  icon. To show just your 
added items, right-mouse-click or control-mouse click on the table, and choose “Show 
Only My Items” from the menu that pops up.

L
Note: To prevent conflicts with ingredients that use USDA items and 

ingredients that use your own, it"s sometimes a good idea to make your 

ingredient description more specific for your own items. For instance, 

instead of just having an ingredient of “1 can cream of chicken soup” 

which might already be mapped to the USDA item, you can leave 

“cream of chicken soup” mapped to the USDA item, and then enter 

something along the lines of “Campbell"s Condensed Cream of Chicken 

Soup” for your ingredient, and then map that to your nutritional item.

Deleting Your Nutritional Items
To delete a nutritional item that you"ve added to the database, you just need to select it, 
and choose Nutrition > Delete Item or press the “Delete Item” button in the toolbar. Note 

that you can only delete items you"ve added, which are marked with .
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USDA Food Groups

Baby Foods

Baked Products

Beef Products

Beverages

Breakfast Cereals

Cereal Grains and Pasta

Dairy and Egg Products

Ethnic Foods

Fast Foods

Fats and Oils

Finfish and Shellfish Products

Fruits and Fruit Juices

Lamb, Veal and Game Products

Legumes and Legume Products

Meals, Entrees and Side dishes
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Nut and Seed Products

Pork Products

Poultry Products

Sausages and Luncheon Meats

Snacks

Soups, Sauces and Gravies

Spices and Herbs

Sweets

Vegetables and Vegetable Products

L
Note: You can show and hide food groups from your searches and from 

the browser by right-clicking, or control-clicking on the nutritional item 

table and un-checking or checking the group in the menu.

71



13

13. Meal Planning

This chapter describes the meal planning feature of MacGourmet 
Deluxe
MacGourmet Deluxe gives you the ability to make weekly meal plans and print calen-
dars and menus. 

Planning Meals 
with the Weekly 
Planner
Mealplan is based 
around a weekly plan-
ner. The planner shows 
you a week at a time, 
and lets you plan meals 
for each week, using 
meals and the recipes 
you want to prepare.

You can move from 
week to week by press-
ing the “Previous Week” 
and “Next Week” but-
tons in the toolbar, or by 
choosing Mealplan > 
Previous Week and 
Mealplan > Next Week. 
You can return to the 
current week by press-
ing the “Current Week” 
toolbar button, or choos-
ing Mealplan > Current 
Week.
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To jump to a specific week, press the “Choose Week” toolbar button and click on any 
day within the week.

Adding Meals and Recipes to your Planner
You can easily add meals and recipes to your planner by using either copy and paste, or 
drag and drop. You can add recipes to a day, or to meals within a day.

To add a meal to a planner day, either select a day and choose a meal from the 
Mealplan > Add menu, or drag and drop a meal from the meals drawer to the desired 
day.

The meals drawer displays the list of available meals available for the planner, and it 
also lets you add and delete meals. The built-in meals cannot be deleted or changed, 
but additional meals can be added. To add a meal just press the “+” button at the bottom 
of the drawer. To delete a meal select a meal and choose the “-” button.

The default times (the times used whenever you create an instance of a meal in the 
planner) for meals can be set in the meals drawer by clicking on the clock icon and 
choosing a time. Times are used primarily when you send your data to iCal. When your 
planner is synced, meals that have times will be placed at those times in your calendar. 
Recipes that aren"t part of meals will be placed at noon.

L
Note: When you delete a meal from the meals drawer, it will be re-

moved permanently and any recipes that are in these meals in the 

planner will be removed from the meal and then added directly to the 

days that included the meals.

Adding recipes to your planner is simple: copy one or more recipes from any MacGour-
met recipe box list and select a meal or day, and then choose Edit > Paste, or just drag 
and drop one or more recipes from a recipe box list to a meal or day in your planner.

Once in your planner, meals and recipes can ordered however desired, just drag and 
drop the items from one place in the planner to another. Recipes can be moved from 
one meal to another or from one day to another in the same way.

L
Note: It"s a good idea for recipes to have a designated course. Courses 

are used to organize sections of your menus, and when you send your 

data to iCal.

Adding Notes to your Weekly Planner
Mealplan also features notes that can be added to any day or meal. Planner notes allow 
items other than recipes to be added, for the purposes of including those things that you 
don"t necessary have or don"t need recipes for.
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Printing a Weekly Planner
Mealplan lets you print your planner, a week at a time. To print a copy of your planner 
for a week, select that week in the planner, and choose:

Mealplan > Print Week

This will print your week, organized by the meals for each day. Recipes for a day that 
aren"t part of a meal are added to the bottom of your printed schedule.

The order of the meals in your planner is determined based on the default times for the 
meals, which can be set in the meals drawer, by clicking on the clock icon of a meal 
row.

Creating Shopping Lists
Shopping lists can be created for any week in your planner, by choosing:

Mealplan > Make Shopping List

When this is done, a new shopping list, created using all of the recipes for the current 
week, is added to the list of shopping lists in the  MacGourmet recipe box window.
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Creating and Printing Menus
Mealplan provides a way to make menus for the meals in your planner by allowing a 
menu to be attached to each meal. To do this, select a meal in the planner and choose:

Mealplan > Attach Menu

This will attach a menu and allow the header and sub-header lines to be set for a menu, 
along with the format for the date to use when printing it. To see what a menu looks like, 
select a meal with an attached menu and choose:

Mealplan > Print Menu

to display the print preview window. There, you can see what a menu will look like when 
printed, and you can choose from various available styles.

The order of the courses in a menu is determined by the order of the recipes in the 
meal, and their courses. So recipes for an appetizer course should come first in the 
meal, and should have their course set to “Appetizer” in MacGourmet. When making 
menus, it"s important that recipes have their courses set appropriately.
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Sending your Planner to iCal
The Mealplanner doesn"t include a monthly calendar view, because it"s based around 
the concept of a weekly planner, a month-based view of Mealplan data can be viewed in 
iCal by sending the planner data to iCal.

Using Mealplan with iCal on Tiger (Mac OS X 10.4)
Before the planner data can be sent to iCal, you need to create a calendar named 
“Mealplan” so that the data has a target calendar. Once that has been done, the data 
will be sent to this calendar when you choose:

Mealplan > Send Planner to iCal.

When the planner data is sent to iCal, iCal cannot be running.

Using Mealplan with iCal on Leopard (Mac OS X 10.5)
When running on Leopard, just choose:

Mealplan > Send Planner to iCal

to send the planner data to iCal. The rest will be taken care of automatically: a new cal-
endar named “Mealplan” will be created, and it will be populated with your planner data.

L
Note: Sending your planner to iCal is a one way operation. Each time 

you send the planner to iCal, the data in iCal gets replaced, so any 

changes made to your Mealplan calendar in iCal will be lost.

It a good idea to have appropriate times for meals set, and for all recipes to be in meals 
when planner data is sent to iCal. When a planner is synced, meals that have times will 
be placed at those times in your calendar. Recipes that aren"t in meals will be placed at 
noon.
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Setting Mealplan Preferences
Mealplan has a tab in the MacGourmet preferences that lets you set the following op-
tions:

Weekly Planner
Week starts on: Specifies the day of the week to start your planner on, currently Sunday 
or Monday.

Printed Planner
Include Saturday and Sunday: Include the weekend days when printing your planner

Include date in planner day titles: Include the of the month and the month number in the 
day headers.

Print Vertically
Print a “Stacked” vertical version of the planner, as opposed to the default horizontal 
planner.
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14
14. Creating Cookbooks

This chapter describes the cookbook feature
MacGourmet Deluxe gives you the ability to easily create PDF cookbooks.

Building a Cookbook
Cookbook creation takes place in the Builder window. The builder window contains your 
library of cookbooks, each one capable of containing one or more chapters with recipes 
and text and image pages.

Recipes are added to 
cookbooks by either 
dragging and dropping, 
or copying and pasting 
them from the 
MacGourmet recipe box 
window. Once in a 
cookbook, they can be 
arranged by dragging 
them from one position 
to another, making it 
easy to list recipes in a 
chapter in the exact or-
der desired.

Creating a cookbook
1. Open the Builder win-
dow and choose: Cook-
book > New Cookbook 
or press the New Cook-
book toolbar button

Cookbooks have many 
options available. The 
optional book cover can 
have a title, subtitle, edi-
tion, footer and an full 
size image. These settings can be changed on the Cover tab of the cookbook editor.
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Cookbooks can also optionally have a table of contents, an index, or author and preface 
information. Additionally, recipe images can be included or hidden. These options can all 
be found on the Detail tab.

Finally, cookbooks can be created with custom page and margin sizes. This allows a 
8.5” x 11” cookbook to be created for printing on a home printer, or a 9” x 7” cookbook 
for a book print-on-demand service.

Chapters
Chapters contain reci-
pes, and can also con-
tain full-page image 
pages. To add recipes to 
a chapter, either drag 
and drop them from the 
MacGourmet recipe box, 
or copy them from the 
recipe box and paste 
them into a chapter. 
Once items are added to 
a chapter, they can be 
rearranged simply by 
dragging and dropping 
them from one location 
to another.

Chapters themselves 
can also be reordered 
by dragging them from 
one location in a cookbook to another.

Chapters can have titles as well as a brief optional summary. They can also include text 
useful for chapter introductions, or stories about the recipes listed.

Creating a chapter:
1. Select a cookbook in the Builder window and choose Cookbook > Add Chapter, or 
press the Add Chapter toolbar button

Text Pages
Text pages allow text to be placed at various locations in a cookbook. For instance, a 
text page could be added to a chapter, to separate one section of recipes from another. 
One could also be added to the end of a cookbook, or to the beginning to provide a fam-
ily history or notes about the book.
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Creating a Text Page
1. Select a cookbook or a chapter, and choose Cookbook > Add Text Page, or press the 
Add Text Page toolbar button

Image Pages
Image pages allow high resolution, full-page-sized images to be added to a cookbook or 
chapter. Image pages are different from the images that are included in your recipes. 
Smaller recipe images will be added to the chapters inline if the recipes have images, 
but image pages allow for any image to be added to a cookbook. This is perfect for full-
sized recipe images, but it also useful as a way of adding personal, family images to a 
cookbook as well.

L
Note: images should be high-resolution and should be in the same ratio 

as your page size. If an image is too small it will be scaled to fit the 

whole page. If an image is too big, it will be cropped to fit within the 

page dimensions.

Creating a Image Page
1. Select a cookbook or a chapter, and choose Cookbook > Add Image Page, or press 
the Add Image Page toolbar button.

Blank Pages
Blank pages are just that: pages with no text or images on them. Blank pages can be 
added between chapters, or to the end of a cookbook, as a way of reserving space for 
notes, or personal handwritten messages. They are also useful to add “space” at the 
beginning of a cookbook. Some book styles actually include an intentionally blank page 
at the beginning.

Creating a Blank Page
1. Select a cookbook, or a chapter, and choose Cookbook > Add Blank Page, or press 

the Add Blank Page toolbar button.
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Creating a PDF Cookbook
The cookbook Builder allows you to create high-resolution PDF files with your recipes. 
These PDFs are suitable for printing or can be shared as digital files.

Creating a PDF cookbook file
1. Select one of your cookbooks in the Builder window and choose Cookbook > Create 
PDF, or press the Create PDF toolbar button.

In the window displayed, choose the theme for the cookbook that you"d like to create, 
and then check the “Show in Preview” button if you want your new cookbook to be dis-
played in the Preview application when the cookbook is completed.
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Publishing and Printing a Cookbook
There are many services that provide self publishing and printing of PDF cookbooks. 
Most allow uploads of PDF files without covers, and then provide a way to add a book 
cover and choose from a variety of bindings for the finished output.

To create a cookbook without a cover, simply uncheck the “Has book cover” box on the 
cookbook editor Cover tab. If a text title page is desired, check the “Has title page” box 
on the Detail tab.

Once you have created your cookbook, you can then upload it to one of many print-on-
demand self publishing services that will let you print one or more copies. Table 14-1 
lists some recommended sites.

Lulu www.lulu.com

CreateSpace www.createspace.com

CafePress www.cafepress.com

Table 14-1

Some of these sites will also allow you to sell your cookbook creation online, which 
could be a great way to share your recipes.

Tips for Creating Your Cookbook
The “engine” that creates your cookbook is limited in that it won"t always know what will 
work best for your output.

Occasionally the page breaks might not be optimal and your recipes may be divided 
over pages in a way that is not satisfying. When this happens, it might be worth consid-
ering modifying a recipe to condense the text, or to make it cleaner, so that the recipe is 
either shorter, or breaks in a more appealing manner.

Some recipe collections might also work better with certain themes. Trying another 
theme might produce a better cookbook with your content. It is also possible to try an-
other style as well. For instance, it might work better for your creation to have recipes 
start an new page after each one, rather than being listed one right after the next.
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Appendix A

Backing Up Your MacGourmet Data
I can"t stress how critical having a good backup plan is. You"d be amazed how many 
people contact us for their serial number because their hard drives have died and 
they"ve lost everything. Files can be accidently deleted, or corrupted too, so it"s always 
a good idea to make copies of your information from time to time.

There are two components of MacGourmet that should be backed up:

The MacGourmetDatabase.mgdatabase file
This is the file you created the first time you ran MacGourmet 2. If you chose to put it in 
Documents, and you regularly back up that folder using something like the .Mac Backup  
application, your information will get saved. If you put it somewhere else, make sure you  
add this file to whatever backup plan you have.

The MacGourmet Application Support folder
This folder stores things you"ve added to MacGourmet, like themes, plug-ins, etc. If you 
install the .Mac Backup QuickPick for MacGourmet, it will automatically back this infor-
mation up to your .Mac server. If you don"t use something like Backup, make sure you 
add the folder Library/Application Support/MacGourmet in your home directory to your 
backup plan.

The application file itself will always be available from our servers, so you can back that 
up, but it"s not critical.

Changing the Location of Your MacGourmet Data
By default, your library is found in the location you specify the first time you run 
MacGourmet 2. To change this location, open Preferences and navigate to the Ad-
vanced tab. Next press the “Change...” button and select the folder that you would like 
to use to store your MacGourmetDatabase.mgdatabase file. Make sure that this folder 
is read/write for any user that will be using MacGourmet. Note that this location is the 
folder that will CONTAIN the database file.

To reset the location to the default, press the “Reset” button.

Note that you need to quit and restart MacGourmet for this change to take effect.
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Changing your database location at launch
You can select an existing library other than your default library at application launch 
time by holding down the option key while the application is starting up. This will display 
an open dialog that lets you choose an existing MacGourmet Database file to load. This 
feature allows you to have multiple recipe libraries if you desire.

Note: When starting MacGourmet without holding down the option key, it will go back to 
loading the default library specified in Advanced preferences.
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