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Section 1: First Encounters with StoryMill

Learn the basics that youʼll need to start writing.



Chapter 1: StoryMill Basics

Welcome to StoryMill!  Part word processor, part database, 
StoryMill 3.0 provides every author with the tools essential to 
writing a best seller; everything from project-wide annotations to 
timelines, an industry first.

StoryMill introduces aspiring authors to multi-level writing 
methods of tracking characters, scenes, and locations, while 
professional writers will appreciate StoryMill's time-saving ability 
to oversee and manage the full creative process with Smart 
Views. Built from the ground up for Mac OS X, StoryMill offers an 
innovative way to channel and fine tune the creative writing 
process.

Although StoryMill provides a large amount of features to help you 
write and track the details of your story more effectively, none of 
them are required!  StoryMill is incredibly flexible; it can simply be 
a no-nonsense place to write and revise using its distraction-free 
fullscreen and powerful annotations, or a complete database of 
every character, location, and scene that makes up your novel.

In order to help you jump straight into writing, this chapter 
introduces the basic interface and concepts behind StoryMill and 
describes how to add, edit, and delete any item in your project.

In this chapter:

• StoryMillʼs central metaphor
• The main project window
• Adding and removing items
• Editing items
• Sorting items
• Annotations
• Adding and managing views
• Searching
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The central metaphor
Before you can effectively make use of StoryMill, you need to 
understand the concepts it is organized around.  StoryMill takes 
scenes as the basic building blocks of writing.  A scene is a 
smaller part of the overall story that may be demarcated by time, 
setting, or content.  There is the text that makes up the scene, but 
the program also recognizes that there are actors (the characters 
in the story), a location (the setting), and other information, such 
as notes, that you as the author need to manage.

Scenes then make up chapters.  A chapter contains the actual 
text of your story.  While scenes are a key organizational 
component of StoryMill, the chapter text is what people will 
eventually be reading.

In addition to the narrative flow of scenes-within-chapters, 
StoryMill allows you to examine the chronological flow of your 
project using timelines.  Because you can view scenes both in the 
order they fall in the narrative as well as the order they fall in time, 
scenes are a powerful way to organize your project.

For some people or writing projects, the concept of scenes as 
building blocks for chapters may not make much sense.  
Fortunately, you can use chapters as generic text containers (and 
disregard scenes entirely) while still making use of StoryMillʼs 
annotations and other powerful writing and organizational aids.  For 
example, each “chapter” could instead be a section of your 
research paper or novella.

Aside from the information that is directly influencing your story, 
StoryMill can also track research and submissions to editors and 
agents, allowing you to take your project all the way from inception 
to publication in one program.
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The main project window and general terms
The project window is where youʼll be 
spending most of your time in StoryMill.  Each 
“project”, be it a short story, a paper for your 
English class, or a novel is saved as an all-in-
one document, and each has its own project 
window.

1 Toolbar: The standard Mac OS X toolbar.

w Soure List: The source list allows you to 
navigate between your projectʼs views.  A 
view is a container for the items in your 
project (chapters, scenes, actors, 
locations, etc. are all items).  You can 
usually tell what a view contains based on 
its name (that is, a scenes view contains 
scenes, a chapter view chapters, etc.).  All 
root level elements in this list are views, 
and you can distinguish smart views from 
the rest based on the purple gear icon  
next to their name.

e Item List: The item list is a sorted list of 
all the items in the currently selected view.

r Metadata Pane: The metadata pane shows specific information 
about the currently selected item.

t Notes / Text Field: Depending on context, this area will either 
contain the text or the notes attached to the selected item.
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Your project is made up of views, each of which contains a list of 
items.  StoryMill provides seven different views, each with a 
different associated item:

• Chapters, which contain the text of your project and are made up 
of scenes

• Scenes, which can have actors and locations associated with 
them

• Actors, which are the characters in your project
• Locations, which are the different settings in your project
• Research, which contains researched information pertinent to 

your project
• Submissions, which are used to track submissions of your 

project to agents and editors
• Generic, which is a catch-all view that can be used for notes, 

tasks, or any number of other things

Smart views are a special kind of view based off of another view.  
A smart view acts like a filter and only shows items that match its 
search criteria.  Smart views have a purple gear situated to their 
left, and use the same icon as the view they are filtering (the 
generic view in the example at left).

Tip:
You can filter any view as if it were a smart view by double clicking it.  
If you currently have rules filtering a normal view, it too will have a 
purple gear icon marking it.  However, the purple gear (and the filter 
rules) will go away after you close and reopen the project (you can 
also remove the filtering by double clicking the view again and 
deleting all the rules).
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Adding and removing items
StoryMillʼs seven items have a diverse amount of information 
attached to them, but how you add and remove them is always the 
same.

To add an item, click the Insert button in the toolbar (the actual look 
of the button will change based on what view you are in).  You may 
also choose Edit→Insert Item or use the hotkey ⇧⌘N.  The new 
item will be inserted immediately after the highlighted item.

When you insert an item, the name field in the metadata pane will 
automatically gain focus, allowing you to immediately name your 
new item.  You may then edit other metadata or the itemʼs notes as 
you desire.

To remove an item, just select it in the item list and click the 
Remove button, choose Edit→Remove Item, or hit ⇧⌘R.

Be careful!
The shortcuts for adding a tag (⇧⌘T) 
and removing an item (⇧⌘R) are very 
close to one another on English 
keyboards!
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Editing items
Editing items should be fairly straight-forward, particularly if 
youʼve used Cocoa applications in the past.

First click the item you wish to edit in the item list.  To change 
its name, use the name field in the metadata pane (you cannot 
change an itemʼs name using the item list).  Edit its metadata 
using the metadata pane, and its notes in the notes area at the 
bottom of the window.  You can also use the status dropdown 
in the item list, and scenes have an additional chapter dropdown.

Like all text areas in StoryMill, an itemʼs notes can contain richly 
formatted text, images, and more.  Use Text→Show Ruler or the 
hotkey ⌃⌘R (control-command-R) to show and hide the default 
Cocoa ruler.  Use the Text→Font menu to control fonts and 
formatting.

All items can be edited in their own window in addition to the project 
window.  Double click an item in the item list to open an item 
editing window where you can edit the itemʼs name and notes 
(shown at right).  Chapters will open a chapter editing window, 
which has other special editing capabilities (see The chapter editing 
window).  The item editing window is useful if you need a larger 
space (for instance, if your notes field has images in it) and also 
can be used to reference item notes while working in another view.

Although the metadata attached to items varies across views, all 
items have a status to track their completion (and which also 
controls the color of the item in the item list), a name, a notes field, 
and tags.  Tags are single words or phrases that you can use with 
smart views for very powerful filtering and organizing (see Tags, p. 
28).

Tip:
Editing an itemʼs name is often the most 
frustrating task for new users.  Remember that 
you have to edit the name in the metadata pane 
to the right!
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Sorting items
By default, you can sort any item list using drag and drop.  
However, you may also automatically sort your list by any column 
by clicking on the column heading, which will become highlighted 
with an upwards arrow in the corner (items are ascending 
alphabetically):

Click a second time to reverse the sort order (descending 
alphabetical order):

Click a third time to remove automatic sorting from the column.  You 
can only sort by one column at a time, and automatic sorting will 
not be saved when you close and reopen the project.

Tip:
Currently, the scenes view is the 
only view that you cannot 
automatically sort, because the order 
of your scenes can affect the order 
of the text within your chapters.

Tip:
You can also sort by the status column.  
Statuses are a way to track your 
progress on individual items, and are 
universal across all of your projects.  
You can use StoryMillʼs default statuses 
or define your own in the preferences 
(see Status preferences, p. 60).
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Annotations
An annotation is a comment attached to a specific piece of text.  In 
StoryMill, you can add annotations to any rich text (such as notes 
areas and chapters, but not plain text inputs like item names).

Like all other extended pieces of text in StoryMill, annotations can 
contain richly formatted text, images, and more.

To add an annotation:

q Select some text.

w Click the annotate button in the toolbar, choose 
Text→Annotate, or hit ⌘D.

e Enter a title for the annotation (optional; only useful in chapters).

r Hit tab or click in the text area of the annotation window and 
enter your annotation.

To edit or view an annotation, click the linked text.  You can hide all 
annotation links using Text→Hide Annotation Marks or ⌃⌘D.

To remove an annotation, select the linked text or move your cursor 
into it and click Remove Note in the toolbar, choose 
Text→Remove Annotation, or hit ⇧⌘D.

Tip:  Keep your hands on the keyboard!  If your cursor is inside some linked text, just hit ⌘' (command-
apostrophe) or choose Text→View Annotation to see the annotation!
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Adding and managing views
By default new projects in StoryMill do not have all views (which 
views are included depends on which template you use to create 
the new document; see Document templates, p. 48).  To manage 
your views use the buttons at the bottom of the source list:

The + button adds a new smart view; the gear button offers a 
number of options to deal with the currently selected view (shown 
above).  You can also right click (control-click for one button 
mice) to open a contextual menu version of the gear menu.

Selecting the gear buttonʼs Manage Views… option (or choosing 
Edit→Manage Views…) to manage your normal (non-smart) 
views.

In the Manage Views window (shown at right), double click to 
rename a view.  Select a view and click the Del button to delete it.  
Type a name in the text field and click Add to add a new view.

After you have added a view, you use the dropdown list to choose 
what type of view it is.  You may also change the type for current 
views that have no items in them.  The text box at the bottom of the 
window describes the currently selected type.

Tips:
- You can only have one Scenes view, 

one Actors view, and one Locations 
view, but you can have multiple 
Chapter, Generic, Submission, and 
Research views.

- You canʼt reorder your views in the 
Manage Views window.  Instead, drag 
and drop them in the source list.
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Searching
In addition to filtering views using smart views and temporary filters 
(see the tip on p. 7), you can search any view using the search bar, 
located by default at the far right of the project window toolbar:

Similar to Spotlight, the search will run as you type.  In most views, 
the itemʼs notes and name are searched.  In chapter and scene 
views, the chapter text is also searched.

To clear a search, click the x icon that appears at the right side of 
the search bar:

Keep in mind that the current version of StoryMill does not search 
anything except an itemʼs name, notes, and text (in the case of 
chapters and scenes).  To search by tags or other information in the 
metadata pane, youʼll need to use smart views or temporary filters.

Tip:
Searches persist across views!  This 
means that if you search for “billy 
bones” in your chapters view and then 
switch to your scenes view, the item list 
will still be filtered based on the search.

If you switch to a view and it has fewer 
items than it should, check the search 
bar!  Forgetting to clear your search out 
may well be responsible for your 
missing items.
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Chapter 2: Scenes, Chapters, Timelines, Tags

Using the information from Chapter 1, you should have a grasp on 
the basics of using StoryMillʼs views and items.  However, there 
are four specific features that form StoryMillʼs core that deserve a 
more in-depth look: chapters, scenes, timelines, and tags.

All of these features were touched on in Chapter 1, but hereʼs a 
quick run-down:

Scenes are the basic building blocks for everything written in 
StoryMill.  Within the scenes view, scenes are organized in the 
order they occur in the written work.  Scenes have a broad 
amount of information attached to them, including actors, 
locations, start and end dates, and storylines.

Chapters provide an advanced writing interface and a way to 
gather scenes into groups.  If you arenʼt organizing or jotting down 
details and backstory, youʼll probably be working with chapters.

Timelines are a second way to look at your scenes.  Whereas the 
scenes view is ordered by when scenes occur in the narrative, the 
timeline orders scenes based on when they fall in time.  Timelines 
put your scenes in context with one another, regardless of 
narrative order.

Tags provide an easy way to organize and sort any item in 
StoryMill in conjunction with smart views.

In this chapter:

• Working in the scenes view
• Chapters in the project window
• The chapter editing window
• Timelines
• Storylines
• Editing scenes in the timeline
• Events
• Tags
• Smart views
• Trial version and registration
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Working in the scenes view
Similar to the chapters view, the scenes view has a mode bar along 
the top of the text area:

Clicking Text will let you edit the text of the scene (what shows up 
in the chapter).  The scenes view, however, defaults to Notes, 
because usually you will be organizing and brainstorming rather 
than writing while working in the scenes view.

You cannot add new scenes in the chapters view; instead, youʼll 
need to add them in the scenes view (see Adding and removing 
items, p. 10).  Once youʼve created a scene, select a chapter in the 
item list drop down or the metadata pane.

Most metadata attached to scenes (shown at right) is unique:

• Chapter: the chapter that contains the scene.

• Status: the sceneʼs status (this field is attached to all items).

• Start Date: the date and time the scene starts.

• End Date: the data and time the scene ends.

• Location: the setting for the scene.  This drop down is populated 
by your locations view (if you have one).

• Storyline: which storyline (in the timeline) the scene is in.

• Actors in Scene: a list of all actors in the scene.  This list is 
populated by the actors view (if you have one).
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Fields with the small up and down arrows in their corner are 
dropdowns; click anywhere in the field to open the dropdown and 
select your desired value.

The start and end date fields accept relative dates such as “today” 
and “yesterday” in addition to specific dates (such as Aug 10, 1747 
or 08/10/1747).

Although the start and end date fields can be useful in the scene view 
for quick reference, they are primarily used for sorting scenes in the 
timeline.  Not every story takes place in the real world, of course, but 
the timeline (and the start and end dates) can still come in handy; just 
pick an arbitrary date to start from, and arrange your scenes relative to 
that date.

To add an actor, click the + button.  A dropdown 
will open with all the actors in your actors view 
(excepting any that are already attached to the 
scene).  Click and drag actors to reorder them.

If you need to add information to multiple scenes 
at one time, you can use the contextual menu 
(shown at right).  Select the scenes you want to 
modify with shift-click or command-click and 
right click them (or control-click for single 
button mice).  From the contextual menu you can 
add tags, set statuses, open an attached actor or 
location in its item editing window, open the 
chapter that contains the scene, and more.

The order of the scenes in the scenes view 
dictates their order in the chapters.  If you are placing chapter text 
in scenes, reordering the scenes will automatically move the text in 
the chapter.

Tip:
Once youʼve added an actor to your 
scene, you can double click their name 
in the list to open their item editing 
window.  This is a quick and easy way to 
see the details about an actor without 
leaving the scenes view.
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Chapters in the project window
There are two places to edit chapters: the project window and the 
chapter editing window.

In the project window, you can view chapters either in the standard 
item list by clicking on the chapters view, or you can toggle open 
the chapters view using the arrow to its left and click on individual 
chapters for the single chapter view.  You can then toggle open 
individual chapters in the same way to see the single scene view.

The chapters view with its accompanying item list is best for setting 
statuses or sorting your chapters.  The single chapter view is best 
for editing a chapterʼs aggregate text in the project window, and the 
single scene view is best for working on a single scene.

The mode bar along the top of the main project window area allows 
you to choose what text you wish to see:

• Chapter + Scenes shows you the chapter text and scene text in 
a single window.

• Chapter shows you the chapter text, which is any text inside the 
chapter that is not contained within a scene.  Chapter text is 
always displayed first, followed by text that is inside scenes 
(ordered based on the scenes view).

• Scenes shows you just the text that is inside scenes (in order).

Tip:
The word count field in the chapter 
viewʼs metadata pane counts all of the 
words in the currently selected items.  If 
you need to know how many words are 
in chapters 1-3, just select the 
appropriate chapters and the word count 
will update accordingly!

The bar at the bottom of the window 
also contains a word count, but it only 
counts the currently selected item (or 
the first selected item if thereʼs more 
than one).
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In the chapters view, the area that is normally devoted to notes 
contains the chapter and scenes text.  Youʼll also notice a bar along 
the bottom of the window that is unique to the chapters view:

The cursor location is the name of the scene (or 
chapter) that the cursor is currently located in; the 
others should be self-explanatory.

In order to help you distinguish between scenes, 
alternating scenes have a light background color 
(shown at right).

Although what is typically the notes area in the 
chapters view contains the chapterʼs text, 
chapters still have notes.  The chapterʼs notes are 
available in the metadata pane.

Tip:
They may not look it, but chapter notes 
are rich text!  You can use bold, italic, 
different fonts, even images if you want.
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The chapter editing window
The chapters view, single chapter view, and single scene view are 
useful for seeing the text of your project in context, but the chapter 
editing window offers a number of features to make text editing far 
easier.

To open a chapter editing window, double click a chapter title in the 
chapters view item list or double click a chapter in the source list.  
Similar to the project window, the chapter editing window has a 
mode bar at the top and a stats bar with cursor location, page 
count, and word count along the bottom.  The one addition to the 
stats bar is a zoom level (shown at right); click it to choose a size to 
display the text without needing to change the font sizes.

Most of the unique features of the chapter editing window can be 
found in its toolbar (if you canʼt see all of the toolbar items, resize 
the window or click the right angle button at the far right to access 
those that are hidden:    ).

• Show Notes Drawer: This opens a drawer with the chapter 
notes.  Chapter notes are a useful place to store general 
information about the chapter as a whole.  Alternatively, choose 
View→Show Notes Drawer or hit ⌘R.

• Print, Annotate, Remove Note: The Print button prints the 
chapter;  Annotate and Remove Note control annotations (see 
Annotations, p. 13).
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     (continued from previous page)

• Annotations: This dropdown contains every annotation in the 
chapter.  Select an annotation in the dropdown to jump to that 
annotation within the chapter editing window.  You can use this 
annotations and this dropdown to bookmark your text (particularly 
useful for long chapters).

• Full Screen: Click this button to enter full screen mode.  You can 
also choose View→Full Screen or hit ⇧⌘F.  While in full screen 
mode, hit escape to return to normal.  StoryMillʼs full screen mode 
is an excellent way to reduce distractions and focus solely on your 
text.

• Highlighter: Select text you wish to highlight and choose a 
highlight color from this dropdown.  The highlight colors available 
are based on your statuses (see Status preferences, p. 60).  You 
can also choose Text→Highlight to highlight selected text.  To 
remove highlighting, select highlighted text and choose “None” in 
the Highlighter or the menu.

• Highlight: The Highlight search bar provides you an easy way to 
find words in your text without needing to use incremental 
searching using the standard find controls (available via 
Edit→Find→Find…).  Type a word or phrase into the Highlight 
bar, and StoryMill will highlight it throughout your document.

To edit the contents of the chapter editing toolbar, right click it and 
choose Customize Toolbar… or choose View→Customize 
Toolbar….

Tips:
- In the current version of StoryMill you 

can only use full screen from the 
chapter editing window.

- Color, margins, and text zoom in full 
screen are all controlled in the 
preferences!  See Full screen 
preferences, p. 59.
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Timelines
Your scenes view, and any smart view based off your scenes view, 
can be viewed as a timeline.  To open a timeline of your active view, 
click the Timeline toolbar button in the project window (shown at 
right), or choose Tools→Timeline.

The timeline window has a unique 
toolbar and interface:

q Grid controls: show/hide the grid, 
and toggle snapping.

w Insert Event: insert an event that 
spans storylines.

e Storylines: storylines group scenes 
horizontally so you can see the 
relationship between them.

r Unplaced scenes: scenes without a 
date and time are arranged along 
the left edge of the timeline in 
narrative order, ready to be dragged.

t Zoom controls: change the 
percentage zoom and the base unit 
of measurement (between minutes, hours, days, and weeks).
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Storylines
The timeline shows the chronological order of your scenes 
(regardless of narrative order).  Within the broader timeline, you 
can then group scenes into storylines.  This allows you to logically 
group scenes which would otherwise overlap:

There are two ways to change or assign a sceneʼs storyline.  If you 
drag the scene into the storyline, it will be automatically assigned.  
Otherwise, right click the scene (or control-click for single button 
mice) and choose Storyline→[Your storylineʼs name] from the 
contextual menu.  You can also assign storylines in the standard 
scenes view metadata pane.

To add and remove storylines, use the + and - buttons at the bottom 
of the storyline pane.  Double click a storyline to rename it.

Drag and drop storylines in the storyline pane to reorder them.  
When you move a storyline, all scenes associated with it will be 
moved vertically in the timeline as well.

Drag the bar between the storylines pane and the timeline to resize 
the storylines pane.

Tip:
Changing the zoom level of the 
timeline does not affect storylines 
because it only affects how much 
time is shown (which is horizontal).
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Editing scenes in the timeline
Hover over a scene to see its start and end date and full name in a 
tooltip (shown at right).  To move a scene, simply drag it.  The 
tooltip will update as you move it about the timeline.

If you try to drag a scene somewhere that it cannot go, youʼll notice 
a rectangular placeholder:

This placeholder shows you where the scene will land when you 
release it.

To change the start or end date but leave the scene otherwise 
stationary, hover your cursor over its left or right edge (the cursor 
will change to a standard resizing cursor) and then drag left or right.

Using the left and right arrow keys you can move the selected 
scene in 15 minute increments.

You can also customize the toolbar to gain access to advanced 
controls for adjusting scenes in the timeline.  To do this, right click 
anywhere in the timeline toolbar and choose Customize Toolbar… 
from the contextual menu, or choose View→Customize Toolbar….

Tip:
If no scenes have a start and end 
date, then the timeline will by 
default start at the date and time 
that you view it.  So if you create 
a new project and open a timeline 
on January 7, 2007 at 10:07 AM, 
your timeline will start at January 
7, 2007 at 10:07 AM.

For a more useful timeline, define 
a start time in the scenes view for 
at least one scene before 
opening the timeline.
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The advanced toolbar options are:

• Nudge Left, Nudge Right: Nudging a scene will move it so that 
its edge is next to the closest scene in its timeline.  For instance, 
take the red scene, which is selected:

Clicking Nudge Right while the red scene is selected will result in 
this:

• Extend Start, Extend End: Extending a sceneʼs start or end will 
add 15 minutes to the sceneʼs start or end.  For instance, if you 
have a scene that goes from 8:00 AM to 10:00 AM and you click 
Extend Start, the scene will change to 7:45 AM to 10:00 AM.  If 
you then click Extend End the scene will change to 7:45 AM to 
10:15 AM.

• Select All, Deselect All: You can use these buttons to select and 
deselect all scenes in the timeline.  Alternatively choose 
Edit→Select All or hit ⌘A to select all scenes, or click any blank 
area of the timeline to deselect all.

Tip:
If you need to arrange a large 
number of scenes, first adjust 
your zoom down (how much you 
zoom will depend on how much 
time passes in your project) and 
select “Weeks” as your unit of 
measurement.  You can then 
drag and drop the unplaced 
scenes approximately where you 
need them, and then fine tune 
their position and length using the 
advanced buttons at a higher 
zoom level and unit of 
measurement.
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Events
An event in the timeline is something that happens at a single 
point in time but that may affect scenes across storylines.  For 
instance, in Treasure Island by Robert Louis Stevenson the first 
man killed on Skeleton Island by the pirates affects Jim Hawkinsʼ 
storyline (because he witnesses it) and also affects Dr. Liveseyʼs 
storyline (because he and the people with him hear the man die).

Click the Insert Event button (shown at top right) to add an event 
to the timeline.  You will see the Event Inspector window:

The event will default to the time at the beginning of the timeline.  
To save your event, type a name for it, optionally type a different 
date and time, and close the Event Inspector.  The event will show 
as a red line with the name near the ruler (shown at right).

Hover over the eventʼs line (where there isnʼt a scene overlapping 
it) to see the eventʼs details.  Double click the line to edit the event 
in the Event Inspector.  Drag the red arrow at the top of the event to 
move it (shown at right).

Drag the red arrow at the top of the event out of the ruler to remove 
the event (just like tab stops in the normal text editing ruler).

Tip:
You can add events to the 
timeline just by clicking where 
you want them to fall!  Just make 
sure to click below the dividing 
horizontal line (the lower half of 
the ruler).
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Tags
Tags are short words or phrases that 
provide a flexible way to attach 
metadata to items in StoryMill.  If the 
metadata, such as name and status, 
that StoryMill provides is enough for 
your project, then you never have to 
use tags.  However, if you want to be 
able to filter views based on custom 
metadata, youʼll need to use tags.

For instance, if you wanted to keep 
track of all the pirates in your novel, 
you could attach a “pirate” tag to each 
pirate in the actors view, and then 
create a smart view to show only 
pirates (shown at right).

To add a tag, click the + button at the 
bottom of the tags area in the 
metadata pane, choose Edit→Add 
Tag, or hit ⇧⌘T.  A blank tag will be 
added.  As you type, it will 
autocomplete if it finds a similar tag in 
the project.  You may also click the 
arrows at the right side of the tag to open a drop down with all past 
tags.  Select the tag you are looking for.

Drag and drop tags to reorder them.  To remove a tag, click the tag 
to highlight it and then click the - button at the bottom of the tags 
area or hit delete.

28 of 61



Smart views
Smart views are very similar to smart folders in the 
Finder and smart playlists in iTunes.  Although you can 
create smart views based off a number of different 
pieces of metadata (the specific metadata depends on 
the type of item), using smart views together with tags 
is often the most efficient way to filter your items.

Click the + button to add a new smart view, choose 
Add Smart View… from the gear button at the bottom 
of the source list, or double click a standard view to 
define a filter and then click Save as Smart View once 
youʼre done.  In the rules window, do the following:

q Type a name for your smart view.

w Optionally, choose a standard view to filter (by default, the view 
that was selected when you created the smart view will be 
filtered).

e Add a rule with the + button.

r Select a metadata field.

t Select a qualifier.

y Enter a search term.  Some metadata (such as status or 
tags) will autocomplete as you type, or you can click the 
arrows in the corner to choose from a dropdown.
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Repeat the steps above to add more steps.  You can 
choose to match either all of the rules or any of the rules 
using the dropdown at the top of the window (see 
screenshot at right).

To remove a rule from the list, click anywhere on it to select 
it:

When the rule is selected, click the - button at the bottom 
left of the window to remove it.

As you add and remove rules, the project windowʼs item list 
will update.  You can move the smart view rules window off to the 
side to see in real time what items your smart view will contain.  
When you are finished defining your smart view, click the Close 
button.

Aside from providing you with a filtered set of items, smart views 
also function as templates for new items.  For instance, if you have 
an actors smart view with the rule “Tags - Contains - pirate” and you 
add an item while using the smart view, the new item will have the 
tag “pirate” attached to it automatically.

An itemʼs notes and name will not be populated in a smart view that 
filters for name or notes, however.  Using smart views as templates 
only works for metadata that has a set number of possibilities (such 
as tags, status, the actors in a scene, etc.); it will not work with 
metadata that is entered as unique text.
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Trial version and registration
You should now be well prepared to jump into StoryMill and 
start writing!  Although there are many small details and 
useful features within StoryMill left to explore, you should 
hopefully have a good feeling for the basic interface and 
how to use some of the most important advanced features.

The StoryMill trial version is completely functional (no 
features are crippled) and allows you to launch the program 
30 times before expiring.  Before you register, whenever you 
launch the program you will be greeted by a splash screen 
that reminds you how many launches you have left and 
provides a place to enter your registration number (show at 
right).

When your demo expires you will still be able to launch 
StoryMill in order to export your work, but you wonʼt be able 
to save or print your projects until you register.

To register, click the Buy License… button on the splash screen, 
choose StoryMill→Buy Now…, or visit the Mariner online store.  
You can also find a boxed version at select retailers; if you bought 
the boxed version, your serial number will be inside the box.

Once you have bought StoryMill, you can enter your serial number 
in the splash screen or in the general section of the preferences by 
choosing StoryMill→Preferences… (or hitting ⌘,).
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Section 2: Working with StoryMill

Discover some of StoryMillʼs more advanced features



Chapter 3: Advanced Text Editing

If you are familiar with other programs that use the default Cocoa 
text editing features (such as the ruler, styles, etc.), then you should 
feel right at home in StoryMill.  Alongside the default Cocoa text 
editing controls, StoryMill also provides a number of useful features 
that make advanced text editing easier.

This chapter covers the tools that make StoryMill a powerful text 
editing environment, including:

• Styling and the ruler

• Spellchecking

• Find and replace

• Window splitting

• Text conversion utilities

Although you can do a surprising amount of editing in StoryMill, 
there are certain features that youʼll need a word processor for, 
including headers, footers, advanced page layout, footnotes/
endnotes, and so forth.  For information on how to export your work 
for use in a word processor see the next chapter, Exporting Your 
Work.

In this chapter:

• The ruler
• Styles
• Spellchecking, find and replace
• Splitting windows
• Conversion utilities
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The ruler
By default, the ruler is on in every text view.  If the ruler is on but 
your cursor is not inside the text view, youʼll see the mini ruler:

If the ruler is off, you can click inside the text view and choose 
Text→Show Ruler or hit ⌃⌘R.  The visible full ruler looks like this:

Use the buttons in the ruler for quick access to styles, text 
justification, line spacing, and automatic lists.

Drag the “T” at the left of the ruler to set first line indent for the 
selected text.  Drag the downward arrow at the left of the ruler to 
set the left margin of the selected text.  Drag the downward 
facing arrow at the right of the ruler to set the right margin of the 
selected text.

To add a tab stop to the ruler, drag it from the tab stop well at the 
far right (which contains, in order, a left tab stop, center tab stop, 
right tab stop, and decimal tab stop).  To remove a tab stop, drag 
it outside the ruler and drop it.

Tip:
You can insert hyperlinks in your text!  
Drag and drop links from your browser, 
or highlight text and choose 
Text→Link… to assign the link 
manually (or to edit linked text).

Tip:
A tab stop in the ruler sets where text will land 
in a paragraph if you hit tab.  Using tab stops 
you can arrange text in columns.

Text at a left tab stop is left justified, text at a 
center tab stop is centered, text at a right tab 
stop is right justified, and text at a decimal tab 
stop is aligned based on its decimal point 
(useful for columns of dollar amounts, for 
instance).
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Styles
Although Cocoaʼs styling support is limited, you can use the Styles 
dropdown in the ruler to assign styles that you often use to your 
text.  Most people wonʼt need to worry about styles, however, since 
you can set your default styling for text views in the preferences 
(see Editor preferences, p. 57).

Select text and choose a style from the dropdown to set text to a predefined style.

To define a new style:

q Format some text. Select it.

w Choose Styles→Other… in the ruler.

e Choose Add To Favorites.

r Type a name, and choose whether to include the font and 
ruler in the style definition.

In the sheet from step e you can use the arrows to jump to the 
first, previous, selected, next, and last styles in the text view.  
Click the Favorite Styles radio button to remove or apply other 
predefined styles.

Keep in mind that styles you define using the ruler will be available 
in all applications that use the default Cocoa ruler.
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Spellchecking, find and replace
StoryMill uses the default Cocoa spellchecking for all of its text 
views.  Choose Edit→Spelling→Check Spelling While Typing to 
have misspelled words underlined in red as you type.

Additionally, you may opt to spellcheck manually.  Choose 
Edit→Spelling→Show Spelling and Grammar (10.5) or 
Edit→Spelling→Spelling… (10.4) or hit ⌘: to open the 
spellchecking window (shown at right).  Use this window to find 
suggestions for your misspelled words.

You can also choose Edit→Spelling→Check Spelling or hit ⌘; to 
jump through the misspelled words in the text view without opening 
the spellchecker window.

Choose Edit→Find→Find… or hit ⌘F to do a find and replace in 
the active text view using the standard Cocoa find and replace 
dialog:

Tip:
As of version 3.0, StoryMill does 
not yet support project-wide find 
and replace.  Use the searchbar 
in the toolbar to find text in 
different items, the highlighting 
bar to find words in the chapter 
editing window, and the standard 
find and replace dialog described 
here to find text in the active text 
view.
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Splitting windows
If you are working in the chapter editing window, you can split your 
text view to both edit and reference the chapter at the same time.

q With a chapter editing window open (see The chapter editing 
window, p. 21), choose View→Split Horizontally or 
View→Split Vertically.

w Drag the bar between the splits to resize them to your liking.

e Choose View→Unsplit or close the chapter editing window to 
remove the split.
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Conversion utilities
StoryMill provides a number of different text conversion 
utilities to make what would otherwise be tedious tasks 
quick and simple.  You can find these utilities in 
Text→Convert (shown at right).

To use one of the conversion utilities, first select the text you 
wish to convert, and then choose the appropriate utility from 
the Text menu.

• To Smart Quotes: All straight quotes in the selected text 
are converted to smart (sometimes called curly) quotes.

• To Straight Quotes: All smart quotes in the selection will 
be converted to straight quotes.

• To UPPER CASE: Selected text will be converted to all 
uppercase characters.

• To lower case: Selected text will be converted to all lower 
case characters.

• To Title Case: The first letter of each word in the selected text will 
be capitalized.
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Chapter 4: Exporting Your Work

StoryMill provides most basic text formatting that youʼll need while 
writing, but for advanced text editing features such as margins, 
headers/footers, and footnotes youʼll need to export your text and 
work in another environment, such as a word processor.  Before 
youʼve finished your project you may want to print all of the 
information youʼve entered so you can go over it by hand.  Or else 
you might want to share your research materials without needing 
to go through your research view to copy and paste everything.

Fortunately, StoryMill doesnʼt just provide you with tools for writing 
and revising your project; it also makes it extremely easy to export 
your work to send to agents, publishers, or just to print a hard 
copy of your scenes so you can mark them up in pen before you 
do revisions.

Since version 3.0, StoryMillʼs powerful exporting system is 
capable of exporting any text that youʼve entered in the program.  
You can also easily create formatted export templates using rich 
text and special keywords within the program.  StoryMill exports 
to a number of different documents, including Word, Word 2007, 
RTF, rich text with attachments (RTFD), HTML, and plain text.

StoryMill ships with a number of basic export templates, but if you 
find that they donʼt quite fit your needs you can easily modify or 
duplicate them as a basis for designing your own custom 
solutions.

In this chapter:

• Exporting basics
• Export templates
• Using export template keywords
• Keywords reference
• Document templates
• Custom document templates

39 of 61



Exporting basics
To export anything out of your 
project, first choose 
File→Export….  The 
exporting window will open 
(shown at right).

The pane on the left contains 
the available export 
templates.  When you select 
an export template, the area 
on the right will be filled with a 
preview of what your 
exported text will look like (in 
some cases this area might 
be blank; for instance if you 
chose the Selected Chapters 
template but the selected 
view was an actors view).

Once you have the template 
that you want, select what 
kind of document youʼd like to 
export to using the dropdown 
in the lower right of the 
window and click the Choose 
button.

A standard save dialog will 
open, allowing you to choose 
a destination and a name for 
your exported file.
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Export templates
You can edit your export templates from the export window.  Once 
youʼve chosen File→Export… either select a current template or 
click the + button at the bottom left to add a new template:

If you add a new template, its name will be highlighted in the 
template list by default, ready to be edited.  Otherwise you can 
double click the templateʼs name to change it.

Once you have the template you wish to edit selected, click the 
Edit button to toggle between previewing and editing mode (shown 
above).  Youʼll see something similar to the screenshot at right.

Words such as $chapters_view$ and %aggregateText% are special 
keywords that are placeholders for the contents of items in 
whichever view youʼre working in.  When exporting, the template 
will loop through all the items in the designated view and stick in 
their specific information in place of the keywords.  In the example 
shown, the chapter text and scenes text (the aggregate text) for all 
items in the chapters view will be displayed, with page breaks in 
between.

Tip:
If you double click the name of a 
template other than the highlighted 
template, you may need to wait until the 
preview has been generated before you 
can edit it (the amount of time will vary 
based on the size of the text to be 
exported and the speed of your 
computer).  This slight lag is normal; the 
program hasnʼt frozen!
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Using export template keywords
Keywords in export templates may initially look very strange, but 
theyʼre actually quite easy to use!  There are two types of 
keywords:

• $keywords$ (dollar sign keywords): Keywords that start and 
end with a dollar sign tell the template which view youʼre working 
with

• %keywords% (percentage sign keywords): Keywords that start 
and end with a percentage sign tell the template what to stick into 
the exported document for each item in the selected view.

If you apply text formatting (such as font, size, bold, 
alignment, etc.) to a keyword, that same formatting will 
be applied to the text that it stands for (see the example 
to the right).

There are certain keywords (such as %name% and 
%status%) that apply to all items and can be used with 
any view.  Others (such as %scenesInChapter%) can 
only be used with a specific type of view.  See the 
Keywords reference for a complete list of keywords.

You can place as many different views in a single export 
template as you like.  The exporter will process all items 
in a view, and then proceed to the next view in the 
exporter and process all of its items (and so forth until it 
hits the end of the template).

Tip:
You can add “.selection” (without the 
quotes) to any view selector ($keywords$) 
to have StoryMill export the selected items 
in the view.  For example, 
$chapters_view.selection$ will only export 
the selected chapters, while $Your View 
Name.selection$ will export the selected 
items in the view called “Your View Name”.
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Keywords reference
Here is a complete reference to all keywords available within 
StoryMillʼs export templates.

View selectors

Keyword Output Keyword Output

$Your View Name$ The view named Your View 
Name (capitalization 
matters)

$locations_view$ The locations view 
(regardless of its name)

$current_view$ The currently selected view $research_view$ The first research view 
(regardless of its name)

$chapters_view$ The first chapters view 
(regardless of its name)

$tasks_view$ The first generic view 
(regardless of its name)

$scenes_view$ The scenes view (regardless 
of its name)

$submissions_view$ The submissions view 
(regardless of its name)

$actors_view$ The actors view (regardless 
of its name)

$events$ The events in the timeline

$keyword.selection$ Replace “keyword” with any 
view selector above to export 
the selected items in the 
given view.
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Document keywords (to be used outside of view selectors)

Keyword Output Keyword Output

%title% The projectʼs title %views% Names of all views

%storyLines% All storylines in the projectʼs 
timeline

%events% All events in the projectʼs 
timeline

Universal keywords

Keyword Output Keyword Output

%name% The itemʼs name %creationDate% The date the item was 
created

%notes% The itemʼs notes %lastModifiedDate% The date the item was last 
modified

%status% The itemʼs status %tags% The itemʼs tags (listed with 
carriage returns between 
each tag)
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Scenes-specific keywords

Keyword Output Keyword Output

%text% The sceneʼs text (what 
shows up in the chapter)

%startDate% The sceneʼs start date

%storyLine% The storyline for the scene %endDate% The sceneʼs end date

Chapters-specific keywords

Keyword Output Keyword Output

%text% The chapter text (what you 
see in Chapter mode)

%scenesInChapter% A list of all scenes in the 
chapter (separated by 
carriage returns)

%aggregateText% The chapter and scene text 
(what you see in Chapter
+Scenes mode)

Actors-specific keywords

Keyword Output

%scenesForActor% A list of all scenes using 
the actor (separated by 
carriage returns)
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Locations-specific keywords

Keyword Output

%scenesForLocation% A list of all scenes using 
the location (separated by 
carriage returns)

Events-specific keywords

Keyword Output

%startDate% The eventʼs date

Submissions-specific keywords

Keyword Output Keyword Output

%address% The first address line %homepage% The submissionʼs homepage

%address2% The second address line %phone% The submissionʼs phone 
number

%city% The addressʼs city %fax% The submissionʼs fax 
number

%state% The addressʼs state %dateSubmitted% The date the submission was 
submitted
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Keyword Output Keyword Output

%zip% The addressʼs zip code %response% The response you received 
to the submission

%email% The submissionʼs email %agency% The agency you submitted 
your project to (the name of 
the submission)

Special keywords

Keyword Output

%page_break% Inserts a page break (useful 
to separate items)
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Document templates
Although exporting text from your project is important, sometimes 
the structure of the project itself is what you want to preserve.  To 
create projects with different structures you can use document 
templates.

By default all new projects use the Novel template.  However, 
StoryMill comes with two other templates or you can create your 
own (more on that in a bit).  Choose File→New From 
Template→[Template Name] to create a new project with a non-
default template (you can set your default template in the 
preferences; see General preferences, p. 56).

What template you use to create a project 
changes what views and items are included in 
the new project.  Take, for instance, the three 
templates that come with StoryMill:

• Novel creates a document with the 
following views: Chapters, Actors, Scenes, 
Locations, Tasks, Research, and a smart 
view called Current Tasks.  The Chapters 
view has a single blank chapter item inside.

• Novel (with submission tracking) is 
identical to Novel with the addition of a 
Submissions view.

• Novel (Snowflake Method) is identical to 
Novel except that it has an additional 
chapters view for storing your snowflake 
work, and a number of the views have items with descriptions on 
how to use the snowflake method.
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Custom document templates
Saving a custom document template is easy.  Simply open a 
StoryMill project, set it up the way you want, and choose 
File→Save as Template….  You will be prompted to enter your 
templateʼs name.  After you enter the name, the template will be 
available in the template list.

To add, rename, or remove templates, choose File→Manage 
Templates….  In the Manage Templates window (shown at right)  
double click a template to rename it, select a template and click the 
Delete button to remove it, or click the Install Template… button to 
install a custom template (for example, one that you downloaded 
from online).

When you are finished managing templates, click the OK button or 
close the window using the standard close button in the upper left 
corner.

The power of custom templates is that they create a new project 
with a specific structure of views and also allow you to easily 
include information via items in new projects.  For example, if you 
had a number of different books or stories that took place in the 
same world, you could save a template with the basic characters or 
details about the world already entered.  Then whenever you 
created a new project with that template, youʼd immediately have 
access to the worldʼs basic information.
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Chapter 5: Tools

A big part of writing is revision and other mundane tasks.  
Whether you need to set a daily word goal, analyze which words 
you overuse, or find cliché phrases, StoryMill has you covered.

This chapter will run through the ins and outs of using StoryMillʼs 
tools to keep the creative juices flowing.  Tools that havenʼt been 
covered in previous chapters include:

• The word frequency tool

• Highlighting clichés

• The progress meter and project goals

• Window fading

In this chapter:

• Word frequency
• Highlight clichés
• Progress meter
• Window fading
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Word frequency
StoryMillʼs word frequency tool, available via Tools→Word 
Frequency…, allows you to track your most frequently used words 
in the currently selected chapter.  At this time, word frequency does 
not work in other views.

To see your most frequently used words, select a chapter in the 
item list or open a chapter editing window and choose 
Tools→Word Frequency… to open the word frequency window 
(shown at right).

The word frequency shows all of the words in the chapter, along 
with the number of times they occur.  By default, StoryMill excludes 
a number of commonly used words from the list (such as “the”, “I”, 
“to”, and so forth).  To view or change which words are excluded, 
click the Exclusions tab.  Use the + button to add words to the 
exclusions list, and the - button to remove them (see screenshot to 
the lower right).

When you have the word frequency tool open, the chapter that it is 
analyzing will have the top ten most frequent words highlighted in 
varying shades of red.  The most frequent word will be darkest, and 
the tenth most frequent the lightest (shown below).  Close the word 
frequency window to remove the highlighting.

51 of 61



Highlight Clichés
The highlight clichés tool does exactly what you would expect it to 
do: it highlights potentially cliché phrases in the selected text view.  
To use it, make sure that your cursor is in a text view, and choose 
Tools→Highlight Clichés.  After StoryMill has processed the text, 
potential clichés and colloquialisms will be highlighted in red:

When cliché highlighting is on, the menu item will have a 
checkmark next to it:

To turn off cliché highlighting, choose Tools→Highlight Clichés a 
second time or start typing in the text view.  Cliché highlighting will 
also turn off automatically if you switch to a new item or view.

Tip:
Highlight Clichés ignores both context 
and adjacent text when it looks for clichés 
and colloquialisms.  For instance, in the 
screenshot at left “a few hands on board” 
is being highlighted because StoryMill 
thinks that “hands on” (as in “Iʼm a hands 
on person”) is cliché.  In this instance, 
however, the phrase is not being used the 
way StoryMill thinks.

Additionally, the phrase “great crowd” will 
have “eat crow” highlighted like so:

StoryMill doesnʼt care that the phrase is 
embedded within other words; it just 
notices a text pattern thatʼs defined as 
cliché.

Moral of the story: take StoryMillʼs 
highlighted clichés with a grain of salt!  
The tool is intended to help you find 
clichés, but just because it highlights 
something doesnʼt mean you necessarily 
should revise or delete it.
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Progress meter
The StoryMill progress meter allows you to track your progress both  
during a single writing session or on the project as a whole.  The 
project meter by default is available in the standard toolbar near the 
search bar:

The progress meter tracks all text typed in chapters (including 
scene text).  As you near your word goal, the progress meter will fill.  
When you reach your goal, the progress meter will optionally notify 
you with an alert sound.

By default, the progress meter in the toolbar will display your 
session progress.  Your session progress is the number of words 
that youʼve typed in a chapter since you last launched StoryMill.  
You can also display your progress towards an overall word goal by 
clicking on the progress meter once:

Double click the progress meter or choose Tools→Progress 
Meter… to open the progress meter window (shown at right).  Click 
the goal numbers to set them, and for session progress click 
“Words” to choose from words, minutes, or approximate number of 
pages.

To set your session progress back at 0, click the Reset button.

Tips:
The goals you set in the project meter 
window apply across projects.  If you 
choose 6,000 words per session as your 
goal, each project will have a 6,000 word 
session goal (even though how close you 
are to that goal will differ per project).

If you want to count text in your session 
goal that you typed elsewhere, paste it 
into a chapter using Edit→Paste and 
Count in Progress or ⌥⌘V.

53 of 61



Window fading
You may find yourself at times wishing to reference information 
outside of StoryMill while you write.  While you can always use 
command-tab and so forth to switch to other applications to 
reference them, StoryMill also provides the option to fade almost 
any of its windows.  Fading causes the window to become highly 
transparent (just how transparent is configurable in the General 
preferences; see p. 56).  To use window fading, you can either add 
the custom toolbar button or choose View→Fade Window.

If you want to use the toolbar button, right click anywhere on the 
toolbar (in either the chapter editing window or the project window) 
or choose View→Customize Toolbar….  Drag the Fade button 
from the sheet to the toolbar:
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Chapter 6: Preferences

For the most part, the StoryMill preferences should be self-
explanatory.  However, if you need to find out specifically what 
something in the preferences controls, this chapter provides a 
comprehensive reference for each section of the preferences.

To access the preferences, choose StoryMill→Preferences… or 
hit ⌘, (command-comma).  By default, youʼll see the general 
preferences:

The toolbar area at the top has buttons for the five different 
sections of the preferences: General, Editor, Quoting, Full Screen, 
and Status.

In this chapter:

• General preferences
• Editor preferences
• Quoting preferences
• Full Screen preferences
• Status preferences
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General preferences
• Serial Number: when you buy StoryMill, you can 

enter your serial number here.

• Check for updates on startup: check if you wish 
to have StoryMill automatically check for updates 
when you launch the program.

• Auto-save documents every [num] minutes: 
set an auto-save interval, or 0 (zero) to disable 
auto-saving.

• When saving write a backup: choose a location 
on your computer or preferably on an external 
drive to save a backup automatically whenever 
you save a project.  Check Also backup to .Mac 
to have StoryMill automatically backup your 
projects to your .Mac documents folder on save.  
If you have Growl installed, you will be notified 
when an autosave successfully takes place.

• Open at startup: choose whether to open a new 
document or the last document you had open when 
you startup StoryMill.

• Default template: choose the template used for 
new documents.

• Fade transparency: drag this slider to adjust how 
transparent windows become when you use window 
fading (see Window fading, p. 54).

Tip:
When you start dragging the fade transparency slider, 
the preferences window will become transarent.  Donʼt 
panic!  Keep dragging the slider until the preferences 
are the transparency that youʼd like your windows to be 
when you fade them.  When you let go of the slider, the 
window will return to its normal opaque self.
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Editor preferences
• Open chapter notes drawer on: this sets the side the 

drawer will open in the chapter editing window when you 
choose Show Notes Drawer in the chapter editing 
window (see The chapter editing window, p. 21).

• Show Ruler: check if you want the ruler on by default.  
Uncheck if you want to manually show the ruler.

• Check Spelling as You Type: check this to have 
StoryMill always check your spelling as you type.

• Sort Bookmarks List: check this to have the bookmarks 
dropdown in the chapter editing window sort annotations 
alphabetically.  Uncheck to have annotations displayed in 
the order they fall in the text.

The rest of the editor preferences set the defaults for text in 
your text views.  Click Select… to choose a default font 
and size using the Mac OS X font picker.  The text shown is 
example text in the font you choose.

For the remaining controls, such as Default line spacing, 
either type the number you want in the box, or use the 
arrow controls to increment up and down.

Changing the defaults will not change any text that is 
already typed.  To do that, you may want to use styles (see 
Styles, p. 35).
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Quoting preferences

The quoting preferences allow you to use smart (sometimes called 
curly) quotes instead of straight quotes.

Check Convert quotes while typing to turn on smart quotes.  You 
can then select a style for your quotes from the dropdown (English, 
French, German, or LaTeX), or insert your own characters into the 
text fields for open and closed quotes if you canʼt find the smart 
quotes that you are used to.

Changing this preference will not change text that has already been 
typed.  To convert straight quotes to smart quotes (and vice versa) 
see Conversion utilities, p. 38.
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Full Screen preferences
• Automatically determine fullscreen margin: check this 

to have StoryMill automatically calculate the left and right 
margin around your text in full screen.  Uncheck this to set 
a horizontal margin yourself using the slider.  To have your 
text stretch from one side of your screen all the way to the 
other, set the horizontal margin percentage to 0.  To have 
the outer 40% of your screen be margin and the center 
60% be text, slide the slider all the way to the right.

• Text Zoom: choose the zoom level for text in full screen.  
This will not affect the zoom level of your text in the 
chapter editing view.

• Text Color: set the color of the text in full screen mode.

• Background Color: set the color of the background in full 
screen mode.

• Hide Annotations: check this to have no visual indication 
of annotations while in full screen mode to truly minimize 
your distractions.

• Show Scrollbar: check this to show the scrollbar while in full 
screen mode along the right side of the screen.  You can always 
scroll with your mousewheel or by moving the cursor in the text, 
regardless of whether the scrollbar is on or not.

• Only When Mouse is Overhead: if you are showing the scrollbar 
check this to only show it when your mouse is hovering over the 
far right side of the screen.
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Status preferences
Statuses are used across projects to highlight text and keep track 
of which scenes and items are in need of work.

q Click the + button to add a new status (or the - button to remove 
the selected status).

w Name your new status.  To rename a current status, double click 
it.

e Select a color for the status.

Drag and drop statuses to reorder them.

Tip:
Different users find different statuses useful.  By 
default StoryMill provides statuses for drafts and 
various stages of completeness, but if you want to 
handle drafts via tags, hereʼs another potential set:

Incomplete (yellow)
Draft (orange)
Needs Work (red)
Final (blue)
Discarded (gray)
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Troubleshooting

If youʼve gone through the documentation and are still having 
problems with StoryMill, weʼre here to help!

For technical support, please email support@marinersoftware.com.  
We make every effort to reply promptly, in most cases within 24 
hours.

We would also love to hear if you have an idea or feature request to 
make StoryMill better!  Email us at idea@marinersoftware.com to 
help us improve our software.

You can also find a friendly community of StoryMill users in the 
Mariner Software forums:

http://www.marinersoftware.com/forum/

Thank you for using StoryMill!  We look forward to hearing from 
you.
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